0

We are using Arc GIS Online to display some point data. In ArcGIS Online we configured the attributes to point to a hyperlink that is located in our gdb. Our GDB contains a field that points to where we are hosting an image of this point (pic2) For some reason this link is ending at the first space even though the image name is in the format NAME STREET NUMBER.tiff with spaces. This format has worked perfectly in the past and arc was able to pull through the spaces without a problem and link to the tiff files, but now it has stopped working. We tried to configure the custom attribute display to link to {HYPERLINK} {HYPERLINK%20} and other combinations but it is still not pulling the proper link through.

Why has this stopped working now, is there a solution short of either changing the file names to remove any spaces or changing the links in HYPERLINK field in the GDB to something like WESTMONT%20ST%20003.0.tiff . Is there something setting we can change or a way to change it in the custom attribute field?

image of problem
(source: gislab.net)
!

edited for grammar

0

Having spaces in files and paths is bad practice and makes it difficult for applications to read/process. The best and easiest fix is to remove all the spaces in your files and directory paths. You can replace the spaces with an underscore "_" which allows for readability. If you need a tool to batch rename/remove "things" from a file(s) you can use a free tool called Batch Rename Utility. http://www.bulkrenameutility.co.uk/Download.php

  • Yeah unfortunately all these file names were done a few years ago by a 3rd party contractor, going forward they are all named properly. I was hoping to avoid having to rename all the files as that will also require reformatting all the strings in the HYPERLINK field in the gdb. – ed.hank Jul 22 '15 at 15:55
  • Replacing the strings in the gdb column is not a difficult task, it can be performed in the Field Calculator. – Ryan Garnett Jul 22 '15 at 17:32
0

A solution to this problem that I found is instead of configuring the attribute, select add link under the Pop-up Media option. From there for some reason it will take a link with spaces in it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.