1

Trying to reproject WMS layers in geoserver from the default of EPSG:4326 to EPSG:3574

Using the default projection works fine. url = /geoserver/wms?service=WMS&version=1.1.0&request=GetMap&layers=ENSEMBLE:global_360x181.air_temp.ht_sfc,base_layers:coastlines&styles=,line&bbox=-180.5,-90.5,180.5,90.5&width=658&height=330&srs=EPSG:4326&format=application/openlayers results in: surface air tempurature grid in EPSG:4326

Changing only the SRS and BBOX only renders the vector data, not the raster data: url = /geoserver/wms?service=WMS&version=1.3.0&request=GetMap&layers=base_layers:coastlines,ENSEMBLE:global_360x181.air_temp.ht_sfc&styles=line,&bbox=-1054375,-105875,2584375,2596875&width=658&height=330&srs=EPSG:3574&format=application/openlayers

results in: enter image description here

The raster layer is there - I can make a getFeatureInfo request, but geoserver styles it as completely transparent. There is absolutely nothing in the geoserver log. I have logging turned on at the 'INFO' level.

I tried editing the WCS Settings on the publishing tab for this layer and explicitly added EPSG:3574 to the Current Request and Response SRS List. No effect. I also verified that in the WMS Settings Limited SRS List, EPSG:3574 is listed.

The GeoWebCache is disabled for this layer.

I am completely stumped. Half-baked ideas welcome.

Update

I just recreated this behavior in both Geoserver 2.7.1 and 2.2.4, so either I am doing something completely wrong, or this behavior has been in geoserver for a long time, which seems remarkable.

Update #2

In an attempt to eliminate any configuration issues in my geoserver:

  1. Downlaoded the latest stable geoserver.war, 2.7.1.1 and installed in Tomcat.
  2. Request the nurc:Img_Sample in EPSG:4326, OK
  3. Request the topp:states in EPSG:4326, OK
  4. Request the nurc:Img_Sample in EPSG:32615, not OK
  5. Request the topp:states in EPSG:32615. works fine.

I get the exact same results as originally described. Transparent image, responds to get feature info requests.

Img_Sample URL in UTM 15N projection:

http://localhost:8080/geoserver/nurc/wms?service=WMS&version=1.1.0&request=GetMap&layers=nurc:Img_Sample&styles=&bbox=166021.44,0.00,534994.66,9329005.18&width=768&height=372&srs=EPSG:32615&format=image/png

Update #3

There is one raster in the default data set in a non-EPSG:4326 projection. The native projection for sfdem is EPSG:26713. This layer renders in both EPSG:26713 and EPSG:4326. Is it possible that geoserver will only reproject when the native SRS is a 'PROJCS'? EPSG:4326 is a 'GEOGCS' - might this make a difference?

  • This might be an Openlayers issue as I can't reproduce it using QGis to make a similar request to my local GeoServer. – Ian Turton Jul 23 '15 at 8:52
  • @iant does this happen in the layer previewer of your local geoserver? This is the open layers instance I made the screen shots from. – DaveParillo Jul 23 '15 at 14:42
  • that's an old and cut down version of OpenLayers - I wouldn't use it for anything. In my version it has been updated to OL3 so isn't comparable – Ian Turton Jul 23 '15 at 14:43
  • I'm using the layer preview as a simple way to take any of my software out of the equation. If I curl a geoserver request & set the format=image/png, I get the same results. – DaveParillo Jul 23 '15 at 14:51
  • url = /geoserver/wms?service=WMS&version=1.3.0&request=GetMap&layers=base_layers:coastlines,ENSEMBLE:global_360x181.air_temp.ht_sfc&styles=line,&bbox=-1054375,-105875,2584375,2596875&width=658&height=330&srs=EPSG:3574&format=application/openlayers There is an error in this request, for a WMS 1.3.0 request the you need to use CRS=EPSG:3574 not srs=EPSG:3574 this will also affect the order of the coordinates in the bounding box. – nmtoken Feb 28 '16 at 12:49
2

This is just a guess, but I assume, its about the distortion inherent to your Projection EPSG:3574 which is extremal because displaying the pole(s). I guess there's only data in your raster layer until around 85°N or something, and you are trying to display data further north.

You could try a projection that is "closer" to EPSG:4326 and then also first query the same BBOX

bbox=-180,-90,180,90
  • No, this is not the problem. Image #1 shows the data is available globally. Image #2 shows I can click on the image & get feature data back, so something should be rendered there. Also, Image #2 shows data as far south as the Black Sea & Caspian sea, which should be more than far enough south, if the problem has something to do with clipping regions north of 85°N. For the record, gdalinfo indicates the corner coordinates for the raster layer extend from -180 to +180, -90 to +90 – DaveParillo Jul 22 '15 at 19:37
  • One could argue I am trying to eliminate distortion by using the equal area projection and that it is the distortion inherent in EPSG:4326 that I am trying to remove, but distortion is not what my question is about at all actually. – DaveParillo Jul 22 '15 at 19:40
  • ok, you're right about the distortion, it's in the EPSG:4326 actually. Still, did you try another projection, if it works? – ulrich Jul 23 '15 at 6:41
  • I have tried several. PDC Mercator (EPSG:3832) and several UTM projections (EPSG:32638, etc.). – DaveParillo Jul 23 '15 at 14:42
  • Does the GetFeatureInfo from your raster layer yield the same value for a unique position in both cases? – ulrich Jul 23 '15 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.