2

So I have a vector layer of polygons in WGS 84 lat/long (i.e. using the automatic projection for lat/long and WGS84 datum). I want to change that to WGS84 UTM 23S in QGIS. I tried doing like online tutorials show (right-click layer, "save as", and choose the CRS you want) but there has been zero distortions to the polygons, even for very big ones comprising tens of kilometers. In other words, it didn't work. Can anybody help? I'm using QGIS 2.8.2.


Somebody please help. It's suppose to be simple, but I can't get my head around this zero distortion problem. Anyone?

2

If you view the layer in QGIS with On-the-fly-reprojectionenabled (which is default if the loaded layers have different CRS). you will not see any difference.

That is the deeper sense of reprojecting: The object stays on the same spot on Earth, but the coordinates change.

If you turn off otf, you will see the layers on different places after zooming to the extent.

  • I didnt try that. What I actually did was open a new project and set WGS84 UTM23S as the project CRS. Then I just added the vector layer which I had saved with UTM coordinates. The shape is the same. Anyways, I did what you suggested. It turns out that the shape is still the same, but the new layer is millions of kilometers away. I'm really confused on how to get this done. It is supposed to be trivial. Please help. – Rodrigues Jul 24 '15 at 21:31
  • Can you add the extent of both layers, as reported by properties, metadata tab? – AndreJ Jul 25 '15 at 4:50
  • FOR THE ONE IN WGS84 LATLONG Extents In layer spatial reference system units xMin,yMin -44.4157,-20.5506 : xMax,yMax -43.1225,-19.5514 Layer Spatial Reference System +proj=longlat +datum=WGS84 +no_defs FOR THE ONE IN WGS84 UTM Extents In layer spatial reference system units xMin,yMin 561209.09,7727205.66 : xMax,yMax 696978.82,7837082.42 Layer Spatial Reference System +proj=utm +zone=23 +south +datum=WGS84 +units=m +no_defs – Rodrigues Jul 25 '15 at 11:33
  • I think I figured part of the problem. The distance between the layers is expected. After all, with OTF projection unabled, QGIS is using utm coordinates as lat/long. That is why they are so distant. However the problem remains that the shape is absolutely equal. If there is one thing to expect from lat/long to utm is distortion. Right? – Rodrigues Jul 25 '15 at 11:36
  • No, all coordinates of vertex points get reprojected, but stay on the same spot on Earth. So you will see no effect with otf on. It's just the coordinates changing. – AndreJ Jul 25 '15 at 12:30
2

You should also change the CRS of the project by clicking the grey planet on the bottom right:

enter image description here

1

I'm using QGIS 2.4, but I think it's the same: click the menu PROCESSING, then TOOLBOX.

In the Toolbox, type REPROJECT LAYER. Click to open the algorithm. You can select the layer you want to change the coordinate system (INPUT LAYER), and it will result in a new layer (REPROJECTED LAYER), with the new coordinate system.

enter image description here

  • I tried that too. It is the same as "right-clicking and save as" with a new CRS. Just found the solution. Apparently opening a new project with UTM CRS and adding the UTM layer won't do. The shape is unchanged. But if I change the current project CRS and enable OTF reprojection there is a slight distortion. Don't know why but that'll do. Thank you. – Rodrigues Jul 27 '15 at 12:43
  • From the docs it should do what you want, and I've used it many times and it works, but I don't know about the distortions. – Marcos Saito Jul 27 '15 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.