3

I would like to have two versions of QGIS (2.8.2 and 2.8.10) in Ubuntu 14.04.

I have tried to do it by using the SIG sem grilhetas tutorial.

However, it didn't install qgis 2.8.2 in my ubuntu 14.04. I have already installed qgis, but was the newest version (2.8.10). I would like to have 2.8.2 and 2.8.10 in my computer at the same time.

When I did above tutorial appeared this error message:

CMake Error: The following variables are used in this project, but they are set to NOTFOUND. Please set them or make sure they are set and tested correctly in the CMake files: QWTPOLAR_INCLUDE_DIR used as include directory in directory /home/clement/dev/cpp/QGIS/src/app used as include directory in directory /home/clement/dev/cpp/QGIS/src/app QWTPOLAR_LIBRARY linked by target "qgis" in directory /home/clement/dev/cpp/QGIS/src/app linked by target "qgis_app" in directory /home/clement/dev/cpp/QGIS/src/app linked by target "qgis_qgisappclipboard" in directory /home/clement/dev/cpp/QGIS/tests/src/app

Anyone help me?

  • What have you researched/tried and where are you stuck? – PolyGeo Jul 25 '15 at 23:01
  • Please edit your question to include those important details, and precisely where you got stuck. Potential answerers do not always read these temporary comments. If you can summarize the steps you took, in English, then you should be able to broaden the pool of potential answerers. – PolyGeo Jul 25 '15 at 23:16
  • Now, is the question more clear? – Diogo Caribé Jul 25 '15 at 23:29
  • Actually, I already planned for a long time to ask a question like this. From my knowledge, there is no tutorial covering this. I wanted to have the recent version installed alongside with the dev-version like it is easily possible on Windows. Now that there is the LTR-version, it would be a good idea to create a documentation how to install the current LTR-version and the latest stable version. One version can be installed normally, the other has to be compiled. It seems to me, that most ppl install the stable/LTR version from the repositories, and compile the new new ones. – Bernd V. Jul 25 '15 at 23:30
  • Sorry, what is "ppl"? – Diogo Caribé Jul 25 '15 at 23:32
2

QGIS now offers the current and the long-term-release version in parallel.

According to https://www.qgis.org/en/site/forusers/alldownloads.html#debian-ubuntu, the repositories are

http://qgis.org/debian/

http://qgis.org/debian-ltr/

to minimize conflicts. Ubuntugis is currently a bit behind, only offering QGIS 2.8.1


Unfortunately, you still can not install both versions in parallel like Windows users can with OSGEO4W, because both share the same name after installation, as well as some additional packages. So the only way to get both is to put one in a virtual box with another (or the same) Ubuntu guest system. You can do the operations that you are missing in your favourite version, and exchange data and project files with shared folders. If you feel uncomfortable with that, you can surely pay a QGIS developer to establish a fully parallelized QGIS LTR instance. You will surely not be the only one desperate for it.

Regarding ECW and MrSID support, both are stuck to GDAL 1.10 on the Ubuntugis platform. Until someone ports them to GDAL 1.11, you have no out-of-the-box support for it.

  • It is good information what you bring for us. But, by repositories we only able to use one version. I have to choose what version you will be install in your computer. Then, I would like to have two versions in my computer at the same time. Thank you. – Diogo Caribé Jul 28 '15 at 2:05
  • Is that the same for installing QGIS 2 and QGIS 3 versions together in ubuntu (18.04) – Kadir Şahbaz May 22 '18 at 16:40
  • Yes, the policy has not changed. – AndreJ May 22 '18 at 16:46
1

if you are confortable building qgis, you could just build all the versions you want and either run them out of the build dir or install them at different location.

My strategy is install LTRs using CMAKE_INSTALL_PREFIX=/usr/local/qgis/28 CMAKE_INSTALL_PREFIX=/usr/local/qgis/214

and in .bash_aliases:

alias qgis-214='LD_LIBRARY_PATH=/usr/local/qgis/214/lib /usr/local/qgis/214/bin/qgis $1 &'

I also have QGIS current out of packages and master out of build dir.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.