2

I’m trying to carry out closest facility analysis in ArcMap 10.2.2 on the network analysis layer created from the OS integrated transport and urban path networks. But when I click "solve" in the network analyst bar, to generate the routes between the incidents (postcode centroids) and facilities (green space access points), its failing to calculate routes for all my incidents.

An error window comes up once the analysis in complete listing hundreds of the incidents which it says are on traversable positions of the network e.g. "Location BS138RG in incidents is on a non-traversable network element position".

Error message after the network analysis has been undertaken, done after clicking "solve"

It repeats this message for 1715 of my incidents, then the list goes on to list 2716 postcodes which it says no facilities can be found for, I assume because of the incidents being on non-traversable parts of the network. All my access points and postcodes were originally located fine when I loaded their locations, shown from the image below. And routes have been calculated fine for about 85% of the incidents, but I can't work out why it's not working for them all, many of the facilities and locations now showing up as errors on the map.

Loading locations of facilities and incidents

I didn't set any restrictions in the analysis settings of the network analysis layer, so assumed this would mean that all parts of the network should be traversable. However, because I set drive time as the impedance, perhaps the problem's that in the speed profile for this impedance, the speeds are set to 0 mph along networks which aren't accessible by cars e.g. paths, bridleways. In which case, perhaps there's no way around some of the incidents being on non traversable parts of the network when calculating drive times, since cars are never going to be able to drive along these types of networks! Or perhaps the problem's that most of my facilities and incidents aren't actually situated on the network. But I thought selecting to "snap to position along network" when loading the locations of each of them, would prevent this being a problem.

3

I just noticed that you also posted your question on the GeoNet Forum. I had the same problem as you and followed your steps to try to get a few of my Destination points routed to, but nothing worked. I finally got the answer and fix I needed.

It turned out that some of the one way road designators in the attribute table were going the wrong direction along a highway (FT instead of TF), so the routing would stop when the road switched directions.

You can see the direction of your one-ways and two-ways by right-clicking on the "road network dataset edges" shape in ArcMap, going to Properties, then Symbology.

Click on the box that says "Arrows..." Click on the box to show the arrows for one-way, both, and none so you can visually see all the restrictions.

It is also helpful to click the button to draw the arrows at the endpoints, so you can see the road junctions.

This really helped me to identify the road segments that were going the wrong direction.

Additionally, it was suggested that I run a service area on the facilities that were located but not routed to, and that I check on the box to generate lines in the Service Area set up box under the Line Generation tab.

This way you can see all the routes going from the facility and where there may be gaps in the routing.

Here is the thread if you want to read it all: https://geonet.esri.com/thread/162773

1

I had this same problem and worked with a tech person at ESRI. Network Analyst does snap the points to the road network. I ran into this problem because some of my points are on mountain tops where there are no traversable roads. The ESRI tech suggested I increase the search radius for the Incident points from the default of 5000m to 8000m for snapping to the network. This solved my problem of unfound points. I ran into this problem again this week for a few Facility points that were properly loaded and sat right on a road network, but weren't found when the analysis ran. I ran a separate Closest Facility analysis on just those 2 facilities, and in the Analysis Wizard I changed the direction of the search from "Incidents to Facilities" to "Facilities to Incidents". That solved that problem. I would also test your theory that the 0mph links are throwing off the program. Maybe try changing them to 1mph to see if that helps.

  • Did using a snapping distance of 8000m really "solve" your problem, or just hide it? A better solution would be account for the fact that you have points on mountain tops. – Richard Law Nov 24 '15 at 20:03
  • I did end up acknowledging that the points were in fact on mountain tops and should not be included in the analysis. – NatalieM Dec 6 '15 at 5:06
1

I ran into the same Problem. For me, it worked out when I used the "Feature To Line" Tool on the roads shapefile before I used it to build the network dataset.
This splits all your roads at intersections which is apparently a good thing to do before you build your network.
I further increased the number of found routes by removing all disconnected parts of the network.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.