1

I am trying to get ArcMap 10.2.2 to place my labels where I want them using the Maplex label engine. I want to stop the labels from both overlapping other features in the same layer, and overlapping a text annotation layer. The result I am getting with my current settings is this:

Current labeling.

As you can see, the two red labels overlap the annotation text (and a bit of a feature too) even though at least one of them should fit into the white available area. It seems like Maplex doesn't consider the low priority user defined zones.

I have the following settings:

  • Position: Offset, and user defined zones where to place them. (Starting from 12 o'clock the wheel reads 7, 3, 1, 4, 8, 5, 2, 6.)
  • Label offset of 1 mm, maximum 500% of desired.
  • No fitting strategy in use.
  • Never remove as conflict resolution. If I uncheck this, the two red labels are not shown at all.
  • 0% label buffer.
  • The feature class has a weight of 1000 (I have tried various other values, but it does not help).
  • The text annotations has weight "high".
  • Using "Best", not "Fast".

Please let me know if any other settings are of interest, and I will add them.

I know that label fitting is more of an art than a science, but I want MapLex to utilize all the available space.

closed as off-topic by PolyGeo Jan 17 '17 at 10:00

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • One thing you could try is in the Label Density tab is to reduce the label buffer. This will allow labels to sit closer to one another and may help your placement. Also have you looked at the label priority ranking table (accessed from the maplex toolbar) and made sure the layers are in the correct order there? – MAJ742 Jul 27 '15 at 10:06
  • Thanks for the input, @MAJ742. I have reduced the label buffer to zero percent, but without any effect. The label priority only contains the two different label classes I have for my features (plus some features without labels at the bottom), and moving them around doesn't seem to change anything. – Anders Jul 27 '15 at 10:48
  • No problem, as you mentioned this is all a bit of an art so I think you're best bet is to continue tweaking settings and seeing what works as I doubt there will be a one button quick fix. – MAJ742 Jul 27 '15 at 10:58
  • Is the "Use Maplex Label Engine" in labelling toolbar checked. If yes then restart arcmap and check it if not checked. – SIslam Jul 27 '15 at 13:11
  • @SIslam: It is checked, and I have restarted ArcMap multiple times while working on this problem. – Anders Jul 27 '15 at 13:21