6

In a raster layer's Style Properties, I can choose pseudocolor render type, and choose a color ramp and classify the raster.

enter image description here

However, when I click the 'Apply' button, or click 'OK', the visualization of the raster never changes. I was able to output a 'colorized' version of the same raster using GRASS plugin. I also reinstalled QGIS 2.8, and was able to adjust and see a raster stylings using the steps I outlined above.

So, can anyone confirm this as an issue, or confirm that there's a mistake somewhere in my process?

I should note that I'm on a Mac, 10.10.4, and I'm using the QGIS provided by KyngChaos, 2.10.1-1 .

Update 1: Here's a screenshot of the rest of my settings.

enter image description here

I have Grayscale set to off in the Style setting. Also, I don't believe grayscale/color-blind Preview is available on the Mac version of QGIS. They're does't appear to be the option where it should be, in the Menu Bar under View / Preview / Photocopy (grayscale) etc. Either way-- I added a shapefile to show color.

Update 2: I've experimented with setting color interpolation to discrete, linear, and exact, but still am not able stylize using Singleband pseudocolor. I've also confirmed that the 'Render' box on the the main map view is checked. Also, I am able to adjust Color Rendering settings, like Hue, Blending Mode, etc., and see the results when clicking 'Apply' or 'OK'.

Update 3: As other Mac users are confirming this, I think it may be a bug. I've created a bug report at the official QGIS issues page.

  • check further down this dialog on the right hand side, you don't have greyscale enabled by mistake? Also, that you've not set Preview mode to Greyscale? – Steven Kay Jul 29 '15 at 19:06
  • 1
    I use Color Interpolation linear. Make sure that the render switch in the status bar is activated. – AndreJ Jul 30 '15 at 17:45
  • @AndreJ, are you running on a Mac, and QGIS Pisa 2.10.1? If you are, then I must have somehow made a mistake with my install. – Tele-Pet Jul 30 '15 at 23:52
  • 1
    I'm on Windows, with QGIS 2.10.1 as well. I can't help out on Mac-only problems. The preview you mention seems to be only in the print composer. – AndreJ Jul 31 '15 at 5:04
  • I recently updated to 2.10 pisa from 2.6 brighton and now I experience the same behavior. Mac OS 10.10.4 – RutgerH Aug 5 '15 at 17:14
4

I can confirm this issue http://hub.qgis.org/issues/13162 with Pisa 2.10.1 on Yosemite 10.10.4.

The best option right now would be to downgrade to 2.8.

Projects with geotiffs that have styled in QGis 2.8 still shows correct in 2.10.1. (When I try to load the same geotiff with 2.10.1, I'm unable to style them.)

  • ... problem still exists ! comments in hub.qgis.org/issues/13162 are a bit confusing and downgrading to 2.8. is more or less just a workaround - not a solution. obviously just a few of us are using macs & qgis ... realease was about midth of july and now we are still discussing whether or not it is a bug. i am just a user and the best i can do is testing and reporting. and that's what i am doing. frustrated (this time !) best – robert tuw Oct 4 '15 at 11:08
  • 1
    According to hub.qgis.org/issues/13162 the matter should be fixed in the latest builds by qgis.dakotacarto.com. – AndreJ Oct 12 '15 at 10:18
0

From QGIS just installed on MAC OSX - vector layer styles do not work properly:

This solved my problem: 
updated matplotlib using terminal 
reinstalled QGIS 2.8 Wien instead of QGIS 2.10 (http://www.kyngchaos.com/software/qgis) 
  • well ... i wouldn't call reinstalling a previous release a solution. bu on hub.qgis.org/issues/13162 is an open bug ticket including a comment: "... any change to the layer properties made in the "Layer Properties" are not applied ... " and the conclusio (ibid.) "... this makes 2.10 unusable for me :( ..." – robert tuw Aug 12 '15 at 18:56
  • At the moment, it is the best you can do to work on with QGIS. Solving the bug is surely better, but it will take some time. – AndreJ Aug 13 '15 at 3:50
  • hmm - still not convinced. in particuliar because i had some troubles with 2.8 - see: gis.stackexchange.com/questions/139787/… ... – robert tuw Aug 17 '15 at 8:26
0

Not ideal but what still works is to load style files. I had a layer already styled but no style file saved. I saved the styling to a qml file and then imported to another layer and that worked. qml files are plain text and so easily edited in a text editor. This is a work around and not a fix.

protected by Community Aug 5 '15 at 19:49

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.