1

I am having issues with accessing the QGIS Web Client on a remote web browser despite getting a working GetCapabilities request.

I have been able to install QGIS Server and QGIS Web Client on the localhost with success using Ubuntu/Debian. As a result, on the local server, I am able to open up a web browser and go to the url: qgis-web-client.localhost and access the default client landing page and open up the local maps, helloworld and naturalearth_110million, with success. Further, I am able to insert new QGIS project files into the same folder where helloworld and naturalearth_110million reside and update the client landing page with success on the localhost.

However, when it comes to a remote browser, I am not able to access the client landing page with all of the created QGIS projects.

I have tried a few different combinations for the installation of QGIS Web Client to enable the remote web browser to no avail: 1. I installed QGIS Web Client on my local directory "/home/johndoe" by performing "git clone https://github.com/qgis/qgis-web-client.git" and then entering in "sudo ./install.sh ~/qgis-web-client/projects" 2. On a separate server machine, I also attempted to install QGIS Web Client on my the directory "/var/www/html" by performing "git clone https://github.com/qgis/qgis-web-client.git" and then entering in "sudo ./install.sh /var/www/html/qgis-web-client/projects"

Are there any tips for configuring QGIS Web Client via Ubuntu/Debian so that a remote web browser may access the data accordingly?

  • I've got my QGIS Web Client working (except for search) on Ubuntu from a remote browser. I've put my web client site in my /var/www/html/qwc/site folder. When I remotely type in my URL: yourdomainname.com/qwc/site/index.html I see something. Also double check your permissions on your site folder. Are you able to see anything at all when you even load the index.html page? – Jan Jul 30 '15 at 22:15
  • not very familiar with the app, but on ubuntu/debian you could try sudo netstat -taupen and see if it's listening for remote connections – wchatx Jul 30 '15 at 22:51
  • Hi Jan, I am able to see the QGIS Web Client landing page when I remotely type in my URL. However, the only links shown on the "Your local maps" on the URL are only those of "HelloWorld" and "NaturalEarth" while I expect to see additional maps that I may see on the local browser's QGIS Web Client landing page under "qgis-web-client.localhost". Furthermore, clicking on the HelloWorld and NaturalEarth links on the remote browser takes me to the GIS Web Browser page with a hanging "Loading map application..." message. – tph018nwu Jul 31 '15 at 13:53
  • Hi wchatx, I checked "sudo netstat -taupen" and do confirm that the associated IP address whereby I should expect to access the web server is "established". Any other thoughts for getting the configuration to work? – tph018nwu Jul 31 '15 at 13:57
  • When you say you're able to get the "GetCapabilities" request working, is it giving you the GetCapabilities of a particular project you've created (or the hello world project) ? You'll know because if you created a project, say one qgs project with one shapefile, and you correctly loaded that shapefile and project into your Apache directory structure (use relative links option in associated QGIS project -> Project -> Project Properties-> Save Paths "relative") or your user directory, you should be able to get a GetCapabilities request result that includes information on that shapefile. – Jan Aug 5 '15 at 2:19
1

I was able to subsequently resolve my issue with accessing the default client landing page remotely. I simply needed to perform the following steps:

  1. edit the qgis-web-client.conf file by inserting a "ServerAlias" for the ServerName qgis-web-client.localhost 1a. enter in the following under ServerName qgis-web-client.localhost: "ServerAlias qgismaps"
  2. edit the /etc/hosts file of the local server 2a. enter in the following: "127.0.0.1 qgismaps"
  3. restart apache2 via "sudo service apache2 restart"
  4. edit the host file of the remote machine 4a. enter in the following: " qgismaps" If the IP address of the local server is "12.345.67.890", then modify the remote machine's host file with the following: "12.345.67.890 qgismaps"

Now, on the remote machine, you should be able to open up a browser and connect to the default client landing page by entering in the URL "qgismaps"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.