2

I use ArcMap 10.2 to produce map document containing a lot of label boxes with line callout. Sometimes, I have so many labels that leaders come very matted. Then I use Illustrator to unravel.

enter image description here

Is it possible to tune Maplex to prevent leaders from superposing labels?

Unfortunately I can't reduce the size of boxes (graphic charter) neither its content. And I need the data exhaustivity.

Here are my Maplex parameters:

  • View unplaced labels

  • Placement quality to best

  • The red, gray and black lines label weight ranking to 1000

  • Leader tolerance = 0

  • Regular placement

  • Label offset = 15 mm with secondary offset between 15 mm and 200 mm

  • Label buffer to 0%

  • Background label and 'Never remove' options unchecked

0

As commented by @hornbydd:

I think the problem with leader lines crossing the text is not solvable, it was being discussed [at Geonet] back in 2012.

There an Esri staff member said:

Unfortunately this is a recurring problem which we have patched a number of times, but have been unable to completely resolve. A fairly substantial rewrite is required to fix it and hopefully we will be in a position to do this soon.

If you have not already done so, I suggest seeing whether ArcGIS Pro may be able to produce a better result because ArcMap was "rewritten" to create that 20 years newer ArcGIS Desktop application.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.