0

after using the vectorizing tool I get the following result (picture). Around the cells you can see a small "boundary". This thin line is transparent and annoying. Is it possible to remove these small transparent areas?

picture

2
  • If you click on that small section does it select the row in which it is in?
    – Ger
    Commented Aug 4, 2015 at 11:42
  • I cannot really hit the small parts. The closer I zoom in I don't see the little sections.
    – Pimpel
    Commented Aug 4, 2015 at 11:44

2 Answers 2

2

Change the style of the vector and make the border the same colour, possibly a bit thicker too. That should mask it. I'm guessing that it isn't a real gap.

Styling

7
  • How can I change the boarder color and thickness?
    – Pimpel
    Commented Aug 5, 2015 at 7:51
  • Added an image to show where to look. This might help too: docs.qgis.org/2.0/en/docs/training_manual/basic_map/… Commented Aug 5, 2015 at 17:23
  • I tried it but without success. I guess the boarders are transparent...that might be the problem.
    – Pimpel
    Commented Aug 6, 2015 at 14:08
  • @Pimpel did you try changing the colours to be the same? If you make the border transparent it will still show up. Commented Aug 6, 2015 at 19:22
  • Do I have to this manually?
    – Pimpel
    Commented Aug 6, 2015 at 19:59
1

simmilar problem here ...
and i've tried all the suggestions form above and found some other sources, like http://gisforthought.com/polygon-outlines-in-qgis/ and How to remove tiny polygon outlines in geoserver sld? ... without beeing successful.
so i finally set up a test-polygon-file with a regular structure based on non-overlapping and gap-less squares (see pic. 1 - with identical point coordinates at the corners). displaying these polyogns with white "Simple Fill", outline style: "No Pen", units: "Map Unit" on top of a magenta project-background shows that "small tansparent outline effect" (see pic. 2) . these "gaps" are

  • not a result of the underlaying polygon-data (non-overlapping and gap-less!)
  • scale-independent ... they vary in size but do not vanish completely in any scale
  • are displayed in qgis as well as in print composer outputs (showing differnt dimensions in bothe of them!)
  • and removing these "lines" by setting corresponding border color manually is just a workaround, which isn't really comfortable in particular if you use a lot of graduated symbols layers.

so, acctually i can't provide answers but give some inputs for narrowing down the problem ... but in 2013 that was discussed in the context of "the gamma parameter of the Java antialiasing" - see andrea aime's comment How to remove tiny polygon outlines in geoserver sld?

pic. 1: enter image description here

pic. 2:enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.