I am working in ArcMap 10.3.0 and exporting through Data Driven Pages (DDP). The DDP export works as expected the first time and for immediate subsequent exports, but if I use DDP to export again after more than a minute or so (the time varies) from the same MXD, the program hangs and I have to shut it down through the Task Manager.

I can tell if it is going to hang up as soon as I click "Export" because the Export window does not show "Page x of x" text. See screenshots here: https://geonet.esri.com/message/536459#536459. Even if I let the computer run for awhile, the "Page x of x" text never appears and the export does not happen. This only happens on subsequent exports after more than a minute from an MXD.

This seems to happen whether I export a single page or the entire document the first time. However if I resave the MXD with a new name and then export, it always hangs up and requires ArcMap to be restarted. The problem seems to occur whether I am creating a new PDF file or overwriting an existing PDF file.

Other information:

  • My map consists of an ESRI aerial basemap (no other raster layers), with five 10000' x 10000' lidar contour shapefiles and about 10 other small vector shapefile layers.
  • My export settings are: 300 dpi resolution & output image quality/resample ratio 1:2.
  • I am working from a data server located in this building, but the connection speed varies.
  • Another co-worker is having the same problems with the same MXDs on his machine.

Edited to add this error message: It appeared after ArcMap was hung up on a subsequent export, and hit "end task" in the Task Manager. This is only the 2nd or 3rd time I've gotten this error message, but I thought it might be relevent. (Also, I don't have an f:/ drive as shown in the error message.)

enter image description here

Someone else had this problem as asked on GeoNet here: https://geonet.esri.com/thread/161564 No solutions were presented to her question so I wanted to ask again here.

Is there any way to prevent ArcMap hanging up on a subsequent DDP export?

Edited to add this code snippet, which produces multiple exports without hanging:

import_path = r"R:\Projects\Project\GIS\MXDs\Project_property_maps.mxd"   # Path of .mxd
export_path = r"C:\Users\user\Desktop\test\Test"   # Path of output file
field_name = "Project_INDEX.Pg_num" # Name of field used to sort DDP
pg_name = "Project_INDEX.Desc_" # Name of field used in PDF file name

mxd = arcpy.mapping.MapDocument(import_path) 
for i in range(1, mxd.dataDrivenPages.pageCount + 1):
   mxd.dataDrivenPages.currentPageID = i
   row = mxd.dataDrivenPages.pageRow
   print row.getValue(field_name)
   arcpy.mapping.ExportToPDF(mxd, export_path + row.getValue(pg_name) + ".pdf") 
del mxd
  • Have you seen similar from the print function. On 10.2 I had a problem where the print dialog would not activate correctly and then arcmap would hang similar to what you describe. Just wondering if they could be related.
    – Brad Nesom
    Aug 10, 2015 at 16:24
  • Also, try exporting 1 page, and then doing it again with 1 page. see if that changes the results.
    – Brad Nesom
    Aug 10, 2015 at 16:29
  • I have a similar problem with some MXDs but not most of them, and I haven't been able to figure out why only a few MXDs do it. In my case, Arcmap just crashes instead of hanging, so at least I don't have to wait to find out that it isn't working. The circumstances are the same: first export from DDP works fine, second time doesn't. Closing and reopening the MXD will allow me to export again.
    – Dan C
    Aug 10, 2015 at 16:38
  • There doesn't appear to be any connection between filenames and the crashing for me. I'm working on a series of figures right now, about 20 MXDs which do have both periods and hyphens in both the MXD filename and the exported filenames. Most of them work fine but not all.
    – Dan C
    Aug 10, 2015 at 17:01
  • There may be something to that, I was just trying to reproduce the problem by exporting and then re-exporting immediately, and it worked fine.
    – Dan C
    Aug 10, 2015 at 17:08

3 Answers 3


Based on comments from @Adam, I used a Python script to export my Data Driven Pages MXD with no problems with hanging on subsequent exports. Using Python for the exports appears to have solved the problems I was having.

I used the following script which I added to an ArcMap Toolbox as a script. (The script will only run through Toolbox, since there are parameters included.)

#Set Input Parameters
mxd = arcpy.GetParameterAsText(0) 
PDFpath = arcpy.GetParameterAsText(1) 
PDFname = arcpy.GetParameterAsText(2)

#Create an MXD object
mxd_doc = arcpy.mapping.MapDocument(mxd) 

#Export to DDP 
ddp = mxd_doc.dataDrivenPages 
ddp.exportToPDF(PDFpath + r"\\" + PDFname + ".pdf", "ALL") 
del mxd, mxd_doc, PDFname, PDFpath

I would like to further modify my script to be able to specify which pages should be exported (instead of defaulting to "ALL") but this works sufficiently for what I need now.


Since this has gotten only comments so far (including one of my own) I'll take a chance and figure the problem (if not some mystery of Windows OS) is caused by up to four interrelated things.

  1. Your background raster(s) are very high resolution
  2. Your export DPI is very large
  3. Your Output Image Quality/Resample Ratio is set to 1:1
  4. The location(s) of your data server(s) and/or connection speed is(are) causing a hiccup

Some combination of these is hanging your DDP export. And by "some combination" it could mean only one of them.

If I had to pick one I would look into the last one, especially if I were using an ESRI Online product or have extremely large data sets on a network or remote drive - even vector data and especially so if we're talking Shapefile (just try using the Measure Tool when there are half a million vertices in your view:).

Unfortunately this hang-up also seems to simultaneously corrupt the .mxd file. At root this seems to actually be a Bug-in-ArcMap™ but I cannot find any indication that ESRI knows of or is doing something about this.

That leaves a labor intensive work-around of

  • Saving your .mxd when you have something ready for publishing,
  • Exporting one time (whether it be a single page, range of pages, or all pages),
  • Then closing without saving,
  • Then opening the .mxd again to repeat the 2nd and 3rd steps for each subsequent export.


Based on the recently linked question (how did I miss that one?) and ESRI being officially unaware - see this PDF here, I'd say it has something to do with the Basemap Service interacting with DDP (especially if the pages rotate the data frame). This problem seems to be unique to 10.3 and 10.3.1 and may not be resolvable without a formal fix.

  • 1) I am using an ArcMap Aerial basemap and no other raster images. 2) My export DPI is 300 which I would not consider very large (but maybe others would??) and 3) my resample ratio is 1:2. 4) I am working from a server in our building but have varying connection speeds. It also uses a lock file system that can cause problems elsewhere. Aug 13, 2015 at 20:19
  • This is a good summary of some potential hangups and the workaround is basically what I've been doing. I'll do some more testing with removing large data sets and see if that seems to help. Unfortunately those will be on my maps, so even if it is not a permanent solution at least it will help understand the problem. Aug 13, 2015 at 20:21
  • Have you tried reinstalling ArcGIS?
    – ianbroad
    Aug 13, 2015 at 20:34
  • @ian I have not tried reinstalling it yet. I may when I have time. Another co-worker is having the same problems/errors with the same files. Aug 13, 2015 at 20:39
  • 1
    @SaraBarnes - If you find your own answer you can post it and take credit for it. Else edit your question. -- I don't often use DDP but I do help others who generate project atlases and such, so I'll be glad to hear what you find out. -- Though I won't be surprised if the answer is - "Install 10.3.2" :)
    – user23715
    Aug 13, 2015 at 20:59

I ran into the same issue today. I called ESRI support and came up with a workaround. The issue is with exporting all data driven pages to PDF, geoprocessing results and scale dependent pages.

The workaround:

Instead of adding the imagery basemap thru the typical basemap button, I added a new ArcGIS server in ArcCatalog and connected to http://services.arcgisonline.com/arcgis/services and dragged the "World_Imagery" layer into my table of contents, then cleared my geoprocessing results and then removed the scale dependent option in data driven pages.

  • What do you mean by "remove the scale dependent option" in Data Driven Pages? I don't see that option. I'm in 10.3.0. Thanks. Nov 19, 2015 at 21:03
  • In the extent tab in the data driven dialog make sure the radio button is set to "Best Fit" or "Center and maintain current scale", it should NOT BE SET TO "Data Driven Scale"
    – GreyHippo
    Nov 20, 2015 at 22:00
  • I'm glad that worked for you, but that is the option I used and I was still getting error messages. I appreciate you posting though - this may be helpful to someone else in the future. Nov 24, 2015 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.