2

I have been trying to find out how to make the SAGA and GRASS kernel density tools work in QGIS 2.8. I have had a lot of trouble trying to get them to work as they produce useless results seen below.

GRASS' v.kernel gives me a solid black square with one upper value and 'nan' (the red box is the region). I have searched for reasons this could have occurred and found this. It says the likely cause of error is my region's number of columns and rows. In my case, I have tried numerous variations in the number of columns and rows and have not found any change to the results.

GRASS v.kernel

In SAGA's KDE, I get this weird 4 square result with only two values for the black and white squares. Each of these squares extend to probably 1000x the size of the point data and I'm unsure as to why. Also, is there a way to perform the analysis with no weights?

SAGA kernel density estimation

I need one of these tools to work because the heatmap plugin can not be used in processing modeler and I need to automate maps for people who do not know how to use QGIS/GIS in general.

  • It looks like your output image has, despite what you have tried, all too poor resolution. In the Saga output the white pixel holds all the points, the grey ones each one point at the border. – user30184 Aug 10 '15 at 8:11
1

You need to change the default values of the radius and and cell size. These values are in degrees (not meters) so keep that in mind. Basically you are getting results but, the resolution quite 'coarse'. Try going down to 0.01 or even lower. This is relative to how far or close your point are to each other.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.