2

Trying to Apply cluster scenario for ArcGIS Server on a test environment, 2 servers Node-02 and Node-03 these 2 servers are connected to a domain controller and have administrative users on the domain.

Now I am trying to add the machine Node-02 to the site that was created on the machine node-03, but I got the following error.

“Failed to register the server machine 'NODE-02.CLUSTER-MOLG.PS'. Server machine 'http://NODE-02.CLUSTER-MOLG.PS:6080/arcgis/admin' returned an error. 'Unable to access the config store on 'C:\arcgisserver\config-store'.'” enter image description here I believe that there is something wrong with ArcGIS server 10.3, since I can navigate to the folder 'C:\arcgisserver\config-store which is located on the machine Node-03 form the machine node-02, and the whole arcgisserver folder is shared with everyone with read and write property, so its not a network error. enter image description here

What might be the issue here?

  • 2
    Looks like you didn't setup your config store pointing to a UNC path. Machine 2 can't resolve "c:\arcgisserver.....". The config store and directories in the initial setup need to be UNC \\gisserver\arcgisserver\...." – KHibma Aug 11 '15 at 13:29
  • Many thanks KHibma this helps to solve the issue. the config store and directories in the initial setup need to be UNC \\MachineName\arcgisserver\ – Ahmad saleh Aug 12 '15 at 12:01
3

Information here on turning a single machine configuration into a cluster.

For this particular issue, the problem was the config store was referenced by the first GIS Server through a local path. When attempting to connect the 2nd GIS Server, it cannot access the local path on the first machine. The config store must be setup with the ArcGIS Server using a share (UNC path), so all GIS Servers can access the config store (and server directories) equally.

1

For the machine name, it should only be the name of the machine and do not include the domain. From your second screen shot of windows explorer, it appears the machine name is only NODE-02. It is looking for a config store based on the machine name so I think this is where your issue is.

Your machine URL of http://NODE-02.CLUSTER-MOLG.PS:6080/arcgis/admin should be correct if the domain is CLUSTER-MOLG.PS.

  • 1
    Thanks crmackey. Using the name only without the domain didn't solve the issue the solution was provided by KHibma – Ahmad saleh Aug 12 '15 at 12:02
1

This is only for documentation, and many thanks for KHibma for the helpful solution. enter image description here enter image description here

the right situation is enter image description here enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.