i've installed mac version from kyngchaos including all required packages ...
... and just noticed the following:

while windows version behaves like expected when trying to render an ordinary tif via "singleband pseudocolor" (see the image) qgis 2.10-win

the same procedure on the current mac-release returns: qgis 2.10-mac

interesting detail: pressing "apply" in mac version doesnt change anything and if you press "OK" and re-open layer properties the "render type"-setting has swiched back to "singleband grey".

even more interesting: "singleband grey" is faulty too: none of the options "color gradient", "min", "max", "contrast enhancement" does affect the way the tif is displayed, neither do the "load min/max values" settings !

anyone any ideas?

  • 1
    It's a bug, reported already - good idea to keep the old versions around as well when QGIS updates.
    – Simbamangu
    Commented Aug 11, 2015 at 11:18
  • thx for information - but i didn't find anything about the singleband grey problem in mac version (Mac OSX Yosemite)
    – robert tuw
    Commented Aug 11, 2015 at 13:33
  • concernig duplicate mark ...
    – robert tuw
    Commented Aug 12, 2015 at 10:58
  • gis.stackexchange.com/questions/156324/… ... just deals with sinlgeband pseudocolor ! ... on my osx 10.10.4. "singleband grey" option seems to be faulty too. but there is no open ticket on hub.qgis.org/issues for "singleband gray"
    – robert tuw
    Commented Aug 12, 2015 at 11:38
  • just noticed the update on hub.qgis.org/issues/13162: "... any change to the layer properties made in the "Layer Properties" are not applied ... " and the conclusio (ibid.) "... this makes 2.10 unusable for me :( ..."
    – robert tuw
    Commented Aug 12, 2015 at 11:57

1 Answer 1


from this topic: QGIS just installed on MAC OSX - vector layer styles do not work properly

I had a similar error with pseudocolor properties on macboook air mid 2011 OS x 10.10.4

This solved my problem:

updated matplotlib using terminal
reinstalled QGIS 2.8 Wien instead of QGIS 2.10 (http://www.kyngchaos.com/software/qgis)
  • just tried steps 3.2.1 - 3.2.4 on mac osx 10.10.4 macbookpro mid 2011 without any problem. any kind of vector-data style operation seem to work properly. did an update of any relevant package (kyngchaos) before qgis install ... my problem seems to affect just raster-data
    – robert tuw
    Commented Aug 12, 2015 at 11:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.