2

I am trying to use the tool to make the join a Mineral Database (excel) with my attribute table. When I check the attribute table, it shows up as "NULL". Why does it causing that and what did I do wrong ?

Can anyone please offer me any suggestions or ideas how do I fix it ? excel/database.

  • 2
    Attribute Table of what software? What Version? Assume: ArcGIS (as .shp) though could be MapInfo, AutoCAD, QGIS... – Mapperz Aug 30 '10 at 17:36
  • Could someone fix the tags for this one? – relet Aug 31 '10 at 8:14
5

The first thing I would try would be to open the Excel spreadsheet and clean out any text or cell formatting that are in it. If that does not work, export the Excel spreadsheet to a text file, then import the text file into a new Excel spreadsheet. I've had similar issues in the past and both solutions have worked. Also, make sure that the fields you are using for the join are the same data type.

| improve this answer | |
8

I've seen this behaviour as well. If Zachary's solutions don't work (which have usually worked for me in the past), the other thing to try is to export the Excel sheet to a DBF and join that instead. I've only done this in ArcGIS, your results may vary depending on what software you're using.

| improve this answer | |
  • 1
    +1, this is my usual approach to dealing with ArcGIS's flakiness with respect to table files. – fmark Aug 31 '10 at 3:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.