1

When i try to move my vertexes from my line feature in QGIS 2.10, the line is getting "separated", also when i delete the vertexes my line is getting holes. Any ideas why?enter image description here

enter image description here

  • 1
    Is that definitely a SINGLE line feature? Not two? – Simbamangu Aug 12 '15 at 9:13
  • 1
    You must have MULTILINESTRING that you edit. The Node tool does really move only the end node of one LINESTRING part but not the end of the other part. After all, there are two separate nodes at that place but from the users point of view it would make sense to have an option to move the both nodes together. Anybody interested can have a try with this geometry MULTILINESTRING (( 924 468, 821 299 ), ( 282 499, 395 383, 593 416, 749 638, 924 468 )) and move the node at the rightmost bend. – user30184 Aug 12 '15 at 9:35
2

The feature that you need was added into QGIS six years ago based on this ticket http://hub.qgis.org/issues/748

The trick you must to do is to drag a rectangle around the end/start nodes for selecting them both so that you can move them together.

enter image description here

enter image description here

However, it you delete the selected nodes the result will be unexpected and surely not what you want. For reducing the number of vertices and keeping one contiguous linestring you should convert and merge/dissolve the multilinestrings into simple linestrings first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.