4

I am currently running the DEM preprocessing on a relatively large (50000 km2 at 30 m resolution) and steep DEM. The objective is to extract the stream network and some morphologic attributes (e.g., slope) of the extracted streams. the problem is that the DEM is quite noisy on the valley bottoms, hence, if I use the standard fill tool in ArcGIS, a majority of valley bottoms is filled, and the information that was available there originally, is lost.

So much for the context. I was using WhiteBox GAT for similar problems in the past, because its breaching Algorithm was great for that objective. Now, I was forced to update my computer to Windows 10, recently. Now I am not able to start the WhiteboxGIS.jar, any more. I have the newest Java version (8.51) from Oracle installed. The problem persist both by clicking on the jar file, or by opening it from the console. Using either method, just nothing happens: no error, no messages in the console, nothing.

In the past I had a similar problem with Whitebox (under Win 7) that was solved by repairing the association between java and the jar files using this tool: http://johann.loefflmann.net/de/software/jarfix/index.html. Now, unfortunately, that method is not successful. I also tried the standards, e.g., reinstalling java.

Unfortunately I also do not have access to another PC with a different operating system to run it there. I am also not an expert on Java, so unziping the jar did not help me understand potential causes for the problem.

Did anybody already trying to run Whitebox under Win 10, or has anybody who is more familiar with JAVA any idea for how I could get this work?

3

Several people have reported similar problems and I believe that it has something to do with how Windows 10 and Java are working together. First, make sure that the latest 64-bit version of the Java Runtime Environment (JRE) is installed on your machine. If you have the latest version of the JRE installed and nothing happens when you double-click the Whitebox GAT jar file, then it is likely that your system does not have Java associated with .jar files. Try linking the Whitebox GAT jar file to Java on the properties menu that pops up when you right-click the WhiteboxGIS.jar file in Windows Explorer. If this still does not work for you, Whitebox will reportedly launch correctly from the Command Prompt. To do so:

  1. Open the Command Prompt (go to the application search and type command prompt)
  2. Change the directory to the folder containing Whitebox. On Windows, this is achieved using the CD command, e.g. CD C:\Users\JohnL\Desktop\Whitebox_3_2_2
  3. Now launch Whitebox by typing the following: java -jar WhiteboxGIS.jar

Unfortunately, we do not currently have access to a Windows 10 computer for testing Whitebox GAT on and so these are the only solutions that we are aware of at present.

EDIT

As a follow up to this answer, Whitebox GAT 3.3.0 was recently released and it includes a WhiteboxGIS.bat file that automates the command-line launch process described above. It is the recommended way of launching Whitebox GAT on Windows computers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.