0

I'm writing a script to automate post and reconcile a target and edit version. I consistently get the warning message "The reconcile process was not performed. The specified target version has no edit versions to reconcile with." I double checked that in the Administer Geodatabase tree view that the edit version is a child of the target version. I'm also the owner since I create those test versions.

I've tried googling the message and found someone asking the same question on Geonet in June 2015 with no answers.

  • What version are you using? There is a gp tool that does this. – Ben S Nadler Aug 23 '15 at 2:25
  • 10.3. The process works fine in model builder and in the script model builder spits out. When I modify the script to be more readable, I get that error. – user22551 Aug 24 '15 at 16:47
  • You will need to post your edited script. – Ben S Nadler Aug 25 '15 at 0:06
2

It seems reconcile versions management is very picky about the input format of the version name string. If you export the geo-processing tool as a python script, the input version (for us) looked like "'\"Domain\\User\".Version Name\"'". I'm not sure why there is a " followed by a ' on the outside of the string, but that is what worked for us.

So ultimately, what fixed the problem for us is taking the version string and adding single quotes around the entire thing. So our version string format was as above: version_string = "Domain\User".Version Name. I took that and surrounded it with single quotes: parameter = "'" + version_string + "'" The script finally accepted that. We got really creative with string modifiers but in the end that's all we needed.

0

Just had a head scratcher this morning, as this error message is confusing and misleading. Thanks for this post, I was able to find the culprit. I was trying to reconcile and post each grandchildren version to parent ( to seek any conflicts on versions) and getting this error (Error says parent version has no children :O). The solution was to get each child version inside a quote and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.