2

On QGIS 2.10, running on Ubuntu 15.04 Linux, I have a project file that has a fairly large number of mainly shapefile layers, which gets to 99% on the slider to the right of where it has a message saying 'Loading layer name of last layer' and then just hangs there, for a long period of time (sometimes an hour) before the qgis process crashes.

I haven't had this fault before, even when working with other projects with large numbers of complex layers, and this fault affects one particular project file for no obvious reason.

I have already tried a couple of different methods of resolving this, firstly by removing this last layer by manually editing the .qgs project file in a text editor, and secondly by disabling all plugins and restarting qgis in case it could be a plugin causing the problem. Neither of these affected the issue. If I edit the .qgs file to remove the last layer, the program hangs instead as it displays 'Loading layer...' for the preceding layer.

I have no reason to think that the data of any of the actual layers are missing or corrupted, and in any case if this had happened I would have expected the "Handle bad layers" message instead.

Does anyone know what kind of situation is likely to have caused this, or how to remedy it?

  • Just a thought: after loading the layers, what is the next part inside the .qgs file? Maybe print composer collections cause the crash? – AndreJ Aug 16 '15 at 16:44
  • After all the layers, there is the <properties> section, which contained a few bits about a couple of plugins that I weren't using and not sure why the were in there. I deleted some of that, and also used "System Monitor" which showed that the memory usage when I tried loading the project, after it got stuck at 99% loading layers, steadily keeps increasing, until it reaches 100% and the system hangs. – David Trethewey Aug 16 '15 at 19:08
  • I wonder if QGIS writes a log file as it loads... – MikeRSpencer Aug 16 '15 at 21:01
  • Have you already reported an issue? – Matthias Kuhn Aug 16 '15 at 23:01
  • I am now strongly suspecting that what happened is I had a couple of big shapefiles, one of them with a .shp file of 1.2GB, joined to a text csv file of over 300MB, and I had duplicated this layer several times in order to have different variations on the styling ready as I have been experimenting with the visualisation. I suspect that somehow all those big joins overwhelmed the memory. In case you're wondering what I was doing have a look at my blog: skrifennow.blogspot.co.uk/2015/08/… . – David Trethewey Aug 18 '15 at 19:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.