1

I am trying to use MCC-LiDAR tool, but I can't get it to work.

Example, when I type:

C:\>mcc-lidar -s 1 -t 1 TMR_428_63.las output_filename.las 

I get the following error message:

Internal program error: version minor out of range

What am I doing wrong? The las file version I'm using is 1.4.

2

Apologies, this is the unfortunate result of a software getting dated and I am not sure that you can get around this without reverting to a previous version of LAS (1.1 - 1.3). To quote specifications of LAS 1.4 "LAS 1.4 moves the file specification from a 32 bit file structure to a 64 bit file structure". This specification of LAS also changed to support waveform packet information. Because of these issues the 1.4 format is not a compatible format with MCC likely due to changes in the public header definitions.

The MCC software is not actively being developed any longer so, this is not something that will be fixed. It is possible to download the source code and modify it accordingly (should just be some changes in how the las file is parsed). The workaround I can recommend is backward versioning the data to a supported version of LAS.

  • Thanks for this. Is it possible that this error is only possible on 64bit OS (i run 64bit win/)? Because i have info that one colleague of mine is running without errors MCC on XP 32bit with same data. – Jost Hobic Aug 30 '15 at 10:55
  • You should be able to force the application to run as 32 bit but, I do find that as a bit odd. The OS should not matter and MCC runs fine. It could be that the since 64-bit numbers cannot be interpreted in a 32-bit OS something is going on at the OS level that I am unaware of. Try changing the compatibility setting of the application by right clicking the icon, selecting properties and then the compatibility tab. If available, select Windows XP as the compatibility mode. – Jeffrey Evans Aug 30 '15 at 15:08
  • It didn't work. I relocated MCC folder from program files (x86) into program files and also run it under XP compatibility mode. Thanks for all your help. If i find solution i will post it here in the future. – Jost Hobic Aug 31 '15 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.