0

I run a Geoserver installment as a service on a Windows Server 2008 R2 machine. I try to add a WMS source but everytime I get timeout-exception. As I need to use a proxy I edited wrapper.conf as follows:

# Java Additional Parameters
wrapper.java.additional.1=-Djetty.home=.
wrapper.java.additional.2=-DGEOSERVER_DATA_DIR="%GEOSERVER_DATA_DIR%"
wrapper.java.additional.3=-Dhttp.proxySet=true
wrapper.java.additional.4=-Dhttp.proxyHost=myProxyS
wrapper.java.additional.5=-Dhttp.proxyPort=8080
wrapper.java.additional.6=-Dhttp.proxyUser=myUsername
wrapper.java.additional.7=-Dhttp.proxyPassword=myPW

I restarted the service after my edits but it does still not work.

My System:
Geoserver 2.6.1 (installed as as Service via windows installer)
Java JDK 1.7
Windows Server 2008 R2

Does anyone have any idea why it is still not working?

  • It looks like you have followed docs.geoserver.org/stable/en/user/data/cascaded/wfs.html and I do not find any error from your side. You should log the web traffic and see if Jetty is now even trying to communicate with the proxy. – user30184 Aug 19 '15 at 7:36
  • You should also make a test without proxy for making sure that everything is OK with the remote WMS. I know it can be difficult from a company network and they may not recommend you to test with your own laptop at home or through public WLAN. – user30184 Aug 19 '15 at 7:46
  • try unchecking use http connection pooling on the DataStore page – Ian Turton Aug 19 '15 at 8:53
  • Connection Pooling is not activated because there are no credentials needed to retrieve capabilities xml. I am going to try that at home but the URL I provide is definitely correct and gives an capabilities document – I tried another WMS as well, still connection timeout. – smartwepa Aug 20 '15 at 9:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.