2

I am trying to publish some ecw files with geoserver 2.7.2 on ubuntu 15.04 x64. I downloaded gdal plugin, gdal_data and native libraries for image-io 1.1.11 and set environment variables; GDAL_DATA, LD_LIBRARY_PATH.

I can see new store types when adding new one (ECW, EHdr, JP2ECW etc.). But when I try to save an ECW store with a valid ecw file which I tested with ArcMap, geoserver crashes with this error:

terminate called after throwing an instance of 'std::length_error' what(): basic_string::_S_create Aborted (core dumped)

Do you have any idea about this problem?

5
  • what does gdalinfo show for the file?
    – Ian Turton
    Aug 19 '15 at 9:53
  • It gives same error: gdalinfo: /home/GDAL_PATH/gdal192-Ubuntu12-gcc4.6.3-x86_64/libgdal.so.1: no version information available (required by gdalinfo) terminate called after throwing an instance of 'std::length_error' what(): basic_string::_S_create Aborted (core dumped)
    – muhalif
    Aug 19 '15 at 10:43
  • Where did you get the gdal plugin from?
    – AndreJ
    Aug 19 '15 at 10:54
  • I downloaded native plugins from demo.geo-solutions.it/share/github/imageio-ext/releases/1.1.X/…. Followed these steps: docs.geoserver.org/stable/en/user/data/raster/gdal.html
    – muhalif
    Aug 19 '15 at 11:00
  • Followed these (gis.stackexchange.com/a/102088/50083) steps and managed to run gdalinfo (gdalinfo ecwfile.ecw) from command line. But when geoserver starting it gives this error: ERROR 1: /usr/lib/gdalplugins/1.11/gdal_ECW_JP2ECW.so: undefined symbol: GDALRegisterMe ERROR 1: /usr/lib/gdalplugins/1.11/gdal_ECW_JP2ECW.so: undefined symbol: _ZTI14GDALPamDataset. Getting same error when importing gdal in python.
    – muhalif
    Aug 20 '15 at 14:05
3

Finally I managed to run ecw plugin inside geoserver version 2.7.2

2
  • This worked for me, except the patch didn't quite apply. Here's my version: gist.github.com/stevage/b0bdade278fa066d4082369f95d47670 Apr 8 '16 at 8:49
  • Also for anyone else a little bit unclear, the "Override generated libs" line means just creating a line like this in your Tomcat init script: export LD_LIBRARY_PATH=/mnt/gdal/ecw/libecwj2-3.3:/mnt/gdal Apr 8 '16 at 8:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.