1

I am very new to mapping and I have loaded a set polygons from a shapefile into ArcGIS Pro. They appear correctly however they have clearly lost (or didn't have in the first place), their longitudinal and latitudinal information as they are currently placed in the middle of the ocean, which I believe is the 0 lat, 0 long position.

I can manually move these polygons but it won't let me save the moves, so when I click 'select', it moves back to the original location. Both of the 'save' and 'discard' buttons are greyed out and cannot be clicked. If I click 'finish' on the move tool then it will snap back to the original location too.

Does anybody have any ideas?

Screenshot of polygons

  • Instead of moving the polygons manually (which could be time consuming and cause inaccuracy in your map) try fixing the issue by resolving a coordinate system issue. See my answer below. – Sara Barnes Aug 21 '15 at 12:57
2

It sounds like you may have a problem with a coordinate system. Instead of moving the polygons manually (as it seem like you are trying to do and Sharm's answer reflects), you should try to correct the coordinate system issue and then the polygons will all appear in the correct location.

This article will give you some direction about how to check the coordinate system of your data and your map. It sounds like your data may not have a coordinate system associated with it.

To check this, follow the first tip at the top of the page:

To see if your data source has a coordinate system defined, right-click the layer in the Contents pane, and click Properties to open the Layer Properties dialog box. Click the Source tab, and expand the Spatial Reference group.

  • Hi, thank you for your response! You are right, there is no co-ordinate information associated with the polygons but unfortunately I don't have access to this data so I am limited to moving it manually, which has the problems described above. Do you have any ideas regarding why this problem is occurring? – Jamie Edgecombe Aug 21 '15 at 14:24
  • @JamieEdgecombe I still think it would be better to try and set the coordinate system than to move the polygons manually. Is there anyway you can find out the coordinate system from the source website of the data? Even though the coordinate system is missing now, you can set it if you can find out what it is supposed to be. – Sara Barnes Aug 21 '15 at 14:27
  • I can't unfortunately, although I agree that would be ideal. I can match it up accurately enough as the polygons follow certain roads quite well making it relatively easy. So, although I know how to move the polygons into their correct location, I can't get them to stay there because seemingly these changes won't save. I am able to save other changes to the file, e.g. turning the polygons into a heatmap, but just not changes to their position, scale etc. Any ideas? – Jamie Edgecombe Aug 21 '15 at 15:16
  • I'm not familiar with ArcGIS Pro (I use ArcMap) but it sounds like you are not able to save edits to your shapefile, but you are able to save changes to your map document. It makes sense that you would be able to save other edits such as symbolizing them into a heatmap as you mention. You may want to contact ESRI Customer Support. – Sara Barnes Aug 21 '15 at 15:20
  • Problem solved! Kind of. It seems that it was a glitch in the programme of some sort because clicking F2, the short cut for saving changes, rather than clicking the save button worked! Now the problem I have, which I guess is as you predicted, is that I cannot share the document because of an error about there not being any spatial information. Which I guess could be an insurmountable problem :/ unless you have any ideas? – Jamie Edgecombe Aug 21 '15 at 16:52
0

From the looks of it these two links should help you out.

http://pro.arcgis.com/en/pro-app/help/editing/select-features-for-editing.htm http://pro.arcgis.com/en/pro-app/help/editing/move-or-rotate-or-scale-a-feature.htm

Basically you have to be in editing mode to make the changes and then save the changes from there.

  • Thank you for your reply! Unfortunately neither of those articles have solved the problem. I can move the polygons but cannot click 'save' in the toolbar afterwards as it is greyed out. Then, if I deselect the shape, it will return to its original position and scale. Do you have any other ideas? Could it be a lock on the polygon file themselves that doesn't let them be edited? I did download them from a website. – Jamie Edgecombe Aug 21 '15 at 14:19
  • If there were a lock it would shoot back an error. Can you edit the location and then export the shapefile? – Sharm Aug 21 '15 at 16:40
  • I think it was a glitch in the programme! Clicking F2, the short cut for saving changes, instead of clicking the button, worked! Thanks very much for your help! – Jamie Edgecombe Aug 21 '15 at 16:53
  • oh wow, weird bug – Sharm Aug 21 '15 at 17:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.