-1

I am very new to ArcGIS and I hope I have over-looked something obvious with this!

I have a set of polygons that have been loaded into ArcGIS Pro 10.3 without coordinate information. Unfortunately, it is not possible for me to get the co-ordinate information however I have been able to move the polygons to the correct position on a world map (it was quite easy because they line up with roads). However, I am unable now to 'share' this data online because I get the error: '20028 Data source has no spatial reference'.

Please does anybody know a way around this? Is there another way of sharing it or, ideally, can I get ArcGIS to work out the spatial references given the positions of the polygons on the map?

1

The spatial reference that your error message is referring to is the missing coordinate system that we worked on on your other question (Moving set of polygons in ArcGIS Pro?).

I would recommend trying to figure out the coordinate system first instead of moving the data manually and then trying to apply a coordinate system (spatial reference). (My reasoning being that the more manipulation you do the data first before trying to assign a correct spatial reference, the more difficult it will be.)

Identifying Coordinate System of Shapefile when Unknown? addresses how to figure out an unknown coordinate system. I particularly like mkennedy's answer since it has more detail. It is for working in ArcMap but I imagine ArcGIS Pro works similarly.

|improve this answer|||||
  • That's brilliant, thanks for the link Sara! I can't check it out until after the weekend now but my fingers are crossed! – Jamie Edgecombe Aug 22 '15 at 9:39
  • Apologies for the slow reply on this. I tried the suggestions on the link but couldn't get it to work on ArcGIS (probably a reflection of my GIS ineptitude rather than the software). I found out, more by accident than anything, that I was able to share the file as a webmap despite having the error and it is appearing correctly online. I did this by not clicking 'analyze' and going straight to 'share' instead. Probably not ideal but a sufficient fix for now! – Jamie Edgecombe Aug 27 '15 at 10:15
  • @JamieEdgecombe Glad you got it working! – Sara Barnes Aug 27 '15 at 12:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.