I already tried this http://hg.orfeo-toolbox.org/OTB-Qgis-plugins/ repository and couldn't get it...

This guy seems to have it: http://www.elance.com/samples/orfeo-toolbox-qgis/24111664/

  • For anyone looking for how to do this on Mac, make sure to scroll down to @JDahlgreen's answer which has some useful tips, especially about changing the download extension from .txt to .run
    – EcologyTom
    Commented Jul 9, 2021 at 14:56

8 Answers 8


Since QGIS 3.8, the OTB provider plugin is part of QGIS core but disabled by default (enable it under Options->Processing->Providers). Install OTB (download from https://www.orfeo-toolbox.org/download/) before enabling the plugin.

Prior to QGIS 3.8, install OTB and add the plugin repository http://orfeo-toolbox.org/qgis/plugins.xml (detailed steps at https://gitlab.orfeo-toolbox.org/orfeotoolbox/qgis-otb-plugin) for the OTB provider plugin.

Example plugin settings on Windows:

Activate: (check the box)
OTB application folder: C:/OTB-6.6.1-Win64/lib/otb/applications
OTB folder: C:/OTB-6.6.1-Win64

Figured I'd leave this answer in case someone sees it now. It seems like they've cleaned this up since it was asked, and that old wiki doesn't link well to the current website:


There are full installation instructions as well here https://www.orfeo-toolbox.org/CookBook/Installation.html where they have downloadable install scripts to run.

If you are using ubuntu, you can also do

sudo apt install aptitude
sudo aptitude install add-apt-repository
sudo apt-add-repository ppa:ubuntugis/ubuntugis-unstable
sudo aptitude install otb-bin otb-bin-qt python-otb

This was the thing that worked for me after 30 minutes of trying a full build from source.


I've been struggling trying to make OTB work on QGIS 3.18.1-Zürich running on a GNU/Linux Debian machine. I finally succeeded, so I guess I'll share my experience here, since it wasn't really obvious.

I have all OTB packages installed by the apt package management system, and the binaries and libraries are located in /usr/bin/ and in /usr/lib/x86_64-linux-gnu/otb/applications/

I enabled OTB in the QGIS options dialog box:

QGIS options parameters dialog box

The tricky part was not to put "/usr/bin/" in the "OTB directory" ("Répertoire OTB" on my French version) where the OTB binaries are actually located, but simply "/usr/". It took me a long while to figure this out.

Hope this may help others.

  • 1
    +5000 thank you - this fixed it for me!
    – Thomas
    Commented Jul 8, 2021 at 9:14
  • sadly this doesn't work for me on 3.22. but I am getting the bug that /usr/bin/bin/ is not found when I select /usr/bin/ so 3.22 is still adding an extra bin/. Commented Nov 29, 2022 at 23:02

I did it following this: http://wiki.orfeo-toolbox.org/index.php/Quantum_GIS_access_to_OTB_applications

  • This link is no longer valid. The procedures must have changed.
    – Pierre
    Commented May 21, 2021 at 9:25

This is how I installed it on Windows 8.1 running QGIS 2.18.16:

  • Download zip file for Windows 64bit version from https://www.orfeo-toolbox.org/download/
  • Unzipped it to a sensible location (i.e. not a temporary location)
  • Start QGIS
  • Go to menu option Processing > Options
  • Expand Providers > Orfeo Toolbox
  • For OTB application folder set the value to be the folder path to the bin folder, for example if you have unzipped the download to c:\scratch then the bin folder would be C:\Scratch\OTB-6.4.0-Win64\bin
  • Set the OTB command line tools folder to the same bin folder
  • Press OK
  • If you get a Wrong value error message about a msys folder you then need to go to Providers > Grass Commands and clear the value in Msys folder, this is some sort of bug in QGIS.
  • Restart QGIS

IMPORTANT: Folder path must not have spaces, so c:\Program Files will not work!

This approach got it working but I have not fully tested all the functionality. The reason is that I was interested in a specific function that it had.


I tried installing Orfeo Toolbox in QGIS on Mac and struggled a lot but eventually managed it. Here's how for any beginners confused by terminology:

https://www.orfeo-toolbox.org/download/ (download MacOS)

Make sure the file does not end in .txt, if it does, remove this so it just ends in .run (On recent Mac OS, you need to Right click and "Get Info" for the file and delete the .txt in the "Name & Extension" box, not just rename it in Finder).

Go to terminal, navigate to your Downloads folder by entering

cd Downloads

Then run these commands:

chmod +x OTB-7.3.0-Darwin64.run


(Making sure that the file path is correct). This will unpack the file.

Then go to QGIS > Preferences > Processing. Click on the Providers drop down menu, and select OTB.

Input the file path name of the otb application folder (will probably be something like /lib/otb/applications)

Then input the file path name of the main OTB folder.

Tick the activate box.

Press OK and you're done!


The right way is to install the new analysis framework and then the (new) plugins for Orfeo (and SAGA).

Announcement and instructions:



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.