1

I am attempting to merge two shapefiles together. Both are line features. I have merged these files before and it worked successfully however due to problems during editing I have to start again and merge the two files once again. However any time I try to merge this time it comes up as a fail and with the results as shown below.

enter image description here

3

It seems that the shapefiles are locked.

In ArcGis 10.x if a shapefile is opened (in ArcMap or ArcCatalog..), ArcGis automatically creates a file with the same name and pcname.numbers.sr.lock This prevent data as shapefiles to be edited if opened in multiple mxds or ArcCatalog in example.

Try to open a new and empty mxd then run the merge between the two, or just remove the files from the mxd you are using, save, and run the merge again. If it fails again, manually delete the .lock files from the folder.

Beware that ArcCatalog is closed during the merge, sometimes it can cause the lock.

  • 1
    Locks definitely seem to be the problem. Keep in mind that ArcGIS can sometimes leave processes running even after you've closed all instances of Map, Catalog etc. So if you still have the problem after closing everything and starting a single instance of ArcMap, check the Windows Task Manager for other instances hiding in the background. I have a batch file I keep on my desktop which automagically kills any ArcGIS process hanging around when the applications are closed, which I run if I have problems with locks not clearing. – Adam May 24 '16 at 23:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.