3

I want to convert Shape data with the QGIS browser in the SQLite database . Unfortunately, the umlauts then appear with a mark (see screen shot ) . I do not want to change the UTF-8 encoding for each Layer . Can someone help me ?

enter image description here

  • Does the shapefile attribute table look ok, and is the encoding of the shapefile layer set to Systemor to UTF-8? – AndreJ Aug 25 '15 at 5:32
  • Shape is okay . The layers are set with system . – user8839 Aug 25 '15 at 6:28
  • It looks like UTF-8 does not support the character. I would use something like LATIN1 for the encoding. This could be exported with ogr2ogr is that was a suitable option, and the encoding could be set for the session. – HeikkiVesanto Aug 25 '15 at 13:41
2

If you export the data using Save As ..., you can change the encoding to UTF-8.

According to my answer for Incorrect display of national characters from Spatialite in QGIS, Windows, there are two ways of loading spatialite data into QGIS, which set the encoding on reading differently. You can try both and see which one works for you.

This bug may be related: http://hub.qgis.org/issues/10944

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.