1

I need to print a map from ArcMap. I'm going to use a plotter and want to print it on a A0 format paper. But...the layout settings are totally driving me crazy! As you can see in the first picture below there are 3 boxes I can play with:

  1. "Printer Paper" (Which is the smallest solid one in the top right corner of the first picture)
  2. "Printer margins" (which is the largest dashed one)
  3. "Map Page (Page Layout)" (which is the largest solid one).

The only one which seems movable and shapeable is the Map Page. I would expect that Printer Paper and Printer Margins to match, but they don't and that seems to be the reason I can't set it right as you can see in the print preview of the second picture.

I'm sure I'm missing something. Any help?

enter image description here

enter image description here

In the picture below I unchecked "Use Printer Paper Settings" and size got inverted compared to previous situation. Still, as you can see in the print preview in the low right corner, the result is not what I want.

enter image description here

  • File -> Page and Print Setup. Here you can select your paper size, page size, orientation, etc. – Maksim Aug 26 '15 at 15:27
  • I know, as you can clearly see in the second picture of my post... – Michele Cordini Aug 26 '15 at 15:28
  • Sorry behind a firewall cant see any images lol – Maksim Aug 26 '15 at 15:29
  • Apologies accepted captain Maksim ;) – Michele Cordini Aug 26 '15 at 15:31
  • I dont understand what is the problem, the layout map is not fully filling the page setup? I think just use the settings you want then you should go back to layout and distribute to fit margins, in the right click menu, i think this may fix your issue. – ed.hank Aug 26 '15 at 15:44
3

First of all I would strongly recommend that you export your map to either a PDF or an image file and use that to plot. This is especially true for very complex maps with lots of layers, rasters, transparencies, annotations, etc.

The Page Print and Setup Dialog has nothing to do with printing. Its sole purpose is to set a physical layout page size of your map. You can select your printer (and their loaded page sizes) which makes it easy to just select your page without having to enter the size manually.

Just select A0, use printer settings and click OK.

On the layout, expand and move the data frame however you like. The purpose of the layout is to arrange all the graphical components on the layout which has the physical dimensions of the final map. The data frame in the layout is like a viewport.

I would not worry much about the little graphic on the dialog box either. I normally just set my page size manually or using Adobe Acrobat but i tried selecting my plotter with the same page size that my map has and checking on the "Use Printer Paper Settings" and "SHow Margins" and the image preview is completely wrong as you can see below but the size and the printer margin is correct:

enter image description here

  • I obtained what I wanted after some attempts, and the comments and answers from all of you guys helped. I unchecked "Use Printer Paper Settings" as Sara suggested, then I distributed my map and fitted it to margins as user3338197 suggested. Finally I exported the map as a PDF as Jakub said and set the print there. It worked! Though, honestly, I'm not sure I understood WHY it worked that way. Setting the page and print has always looked very tricky to me, especially on ArcGIS. i.e. it is quite confusing that little box in the low right corner of the Page and Print Setup. Anyway thank you! – Michele Cordini Aug 28 '15 at 10:46
2

http://gislab.net/pics/3.jpg

This is what you need to do i believe, right click on the map part you created (not the margins Arc wants to put the map in) then goto distribute, then goto fit to margins. This will make your map fit the margins of your layout choice.

I would have put in comments, but it wouldnt let me

  • 1
    From Michele's third screenshot, it looks like the data frame is already lined up with the margins in layout view. – Sara Barnes Aug 26 '15 at 16:39
  • Yeah to be honest I am a little confused as to what the actual issue is. The print preview, ie the box in pic2 that is squished into the bottom left corner, never looks correct for me, it only matters how the picture looks in the Layout view. Once its distributed it should print just fine. – ed.hank Aug 26 '15 at 16:46
  • actually i think in the second picture her margins were made to fit the size of the map, instead of making her map fit the size of her required layout margins. – ed.hank Aug 26 '15 at 16:57
  • his*, not hers ;) – Michele Cordini Aug 28 '15 at 10:25
  • I obtained what I wanted after some attempts, and the comments and answers from all of you guys helped. I unchecked "Use Printer Paper Settings" as Sara suggested, then I distributed my map and fitted it to margins as user3338197 suggested. Finally I exported the map as a PDF as Jakub said and set the print there. It worked! Though, honestly, I'm not sure I understood WHY it worked that way. Setting the page and print has always looked very tricky to me, especially on ArcGIS. i.e. it is quite confusing that little box in the low right corner of the Page and Print Setup. Anyway thank you! – Michele Cordini Aug 28 '15 at 10:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.