2

I am trying to import an Excel spreadsheet with a field that has more than 255 characters.

Do I have to convert the Excel table to a file geodatabase table first in order to view this field in ArcMap?

How can I view this field in ArcMap without using a hyperlink to the Excel table and without writing a script?

  • 2
    I'm not sure I understand what the problem is here... do you have a large field in Excel and want that imported into a geodatabase or is it that you want to export your feature class into an excel table? Is the data spatial or not (just a table)? Can you expand a little more on what you have and what you want to achieve please. – Michael Stimson Aug 27 '15 at 3:46
  • 1
    What version of ArcGIS for Desktop are you using? Additional Excel support came in at around 10.2.1 I think. When you say "geodatabase" do you mean a file geodatabase (*.gdb) or another flavour? – PolyGeo Aug 27 '15 at 3:51
  • 1
    You don't really use a geodatabase to "view" fields, regardless of width, and certainly not in files of other formats. Geodatabases store data. You'd need to transfer the data, then choose a client to view it. – Vince Aug 27 '15 at 4:16
  • I have edited the question for better understanding , – sarah Aug 27 '15 at 9:04
  • Related, and possibly duplicate as originally worded: gis.stackexchange.com/questions/75092 This sounds like a display issue in the attribute table. You may want to check the help files, particularly related to table display options and setting widths, heights, and wrap. See help.arcgis.com/EN/arcgisdesktop/10.0/help/index.html#//… for starters. – Chris W Aug 29 '15 at 19:21
2

Assuming that you are using a recent version of ArcGIS for Desktop, and I have not tested, but you should be able to use the Excel To Table tool to do this:

Converts Microsoft Excel files into a table.

I frequently use fields of 4,000 characters in file geodatabase tables and feature classes.

  • 4000 characters for a field name? :) How come you really need them to be so long? ;) – Alex Tereshenkov Aug 27 '15 at 9:42
  • @AlexTereshenkov Of course not - 4,000 is field length not the length of the field name :-) – PolyGeo Aug 27 '15 at 9:50
  • Ah my bad :) was thinking of the name length :) it makes sense now. – Alex Tereshenkov Aug 27 '15 at 10:01
  • It showed the lengthy field. However , it cuts off some of the words.. y is that? Is the text suppose to word wrapped before importation? i did not word-wrap the text. – sarah Aug 27 '15 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.