3

I have a method that does a simplification of geometries. I have used this common code since ArGIS 9.2 without issues and it still works fine in ArGIS 10.2.2. Recently I upgraded a project to 10.3.1 and the simplify on the topology will every know and again freeze for anything between 30 seconds and 3 minutes. It doesn't happen every time and I have tested this on a simple polygon feature in a file geodatabase. Testing this on the same polygon feature in ArcGIS 10.2.2 does not give the performance issue. The code I use is:

    public IGeometry GetSimplifiedGeometry(IGeometry inGeometry)
    {
        var topo2 = inGeometry as ITopologicalOperator2;
        if (topo2 == null)
        {
            inGeometry.SnapToSpatialReference();
            return inGeometry;
        }
        topo2.IsKnownSimple_2 = false;
        topo2.Simplify();
        inGeometry.SnapToSpatialReference();
        return topo2 as IGeometry;
    }

Does anyone know what the problem could be?

  • 3
    Sounds odd, have you reported this to ESRI? – Hornbydd Aug 27 '15 at 10:07
  • Yes we filled in a form to report the bug to Esri and also supplied a small test App to simulate the problem. It will probably take a few days for them to get back to us. But if someone has a work around to the issue it would be great. – Samuel Aug 30 '15 at 15:24
  • @Samuel, did you get an answer from ESRI about this problem? – Maxim Jan 19 '17 at 8:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.