2

I'm having this weird thing when making two different WMs requests. The requests differ by the requested BBOX, meaning two different image-regions, yet the requested regions do overlap. And now for the weird part; It seems that the resulting images have been through some kind of an histogram manipulation (equalization perhaps...) resulting the overlapped area between the two requests to be in different colors.

The problem worsens when making client-side applicative tiles via WMS, resulting in a bizarre transition between tiles.

Hence the assumption that GeoServer automaticly decides to make some-kind of manipulation for my WMS requests.

I've looked for a solution online and the only thing related was GeoServer's RasterSymbolizer which can be configured to make histogram manipulations if configured so for rasters in their SLD file.

Looking at my raster's SLD file shows it's only configured with the opacity option (and nothing about the histogram / normalize options).

Bottom line, Is my assumtion correct? and if so, what am I suppose to do to correct it (how to stop GeoServer from messing with my rasters?)

  • Is it your own GeoServer and you have an access to all logs and configuration files? – user30184 Aug 27 '15 at 14:37
  • 1
    can you add your SLD (or at least the relevant part) you may have triggered a default contrast enhancement – Ian Turton Aug 27 '15 at 16:53
  • And which version are you using? – Ian Turton Aug 27 '15 at 16:53
1

I am assuming your data is 16 bits or float/double.

GeoServer prior to rendering has to convert this data to 8 bits hence does a local linear contrast stretch that computes local maximum. In a tiled client this might lead to stretching data differently in different portions of the map.

In the upcoming 2.8 release we are going to support more advanced options to stretch your data (and more is coming). Check this link for more info.

Af of now, the best thing to do is to perform some sort of contrast stretch on your data prior to ingesting in GeoServer.

Hope this helps, Simone.

  • Hi Simone, the link doesn't work anymore, can you provide an updated version? Thanks. – Thomas Jul 18 '17 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.