I am using ArcGIS 10.2.2 and ModelBuilder. I have a set of models that work and have been tested.

I notice that if I run through the models one after another the open dialogue becomes very slow to open and sometimes freezes. However if I close and re-open ArcCatalog before running, then the model opens OK. This is consistent behavior on different PCs.

My question is, is there some command, or python script I can add at the end of the model that will cause a "re-set" in the same way as closing ArcCatalog? I found a tool on clear cache, but it only relates to ArcSDE.

This is probably yet another quirk of ModelBuilder, but any shared experience would be useful to know.

  • 1
    Remove all in Results window helps as well
    – FelixIP
    Commented Sep 1, 2015 at 9:35

2 Answers 2


At one time I was running particularly large models 500+ elements with lots of iteration that frequently bailed, and like you I found that starting ArcCatalog immediately prior to running them gave them a much better chance of succeeding.

I also tried to re-start my PC before starting ArcCatalog and to not do any other lower priority jobs while running these models.

If I used the Windows Task Manager to monitor such jobs I would see memory usage build up to what was available, so my assumption was that my models were simply exhausting the RAM available.

This is somewhat anecdotal, but when I upped the RAM from 4Gb to 12Gb, the same models usually completed without issue.

I am not aware of any way to "re-set" in the same way as closing ArcCatalog.

If starting on a new job like the one I describe above. I will now always use ArcPy rather than ModelBuilder because, after an initial learning hump, it becomes much quicker and easier to develop with, and results in jobs that run much more reliably.

  • hi, thanks for your comment. Yes , with benefit of hindsight i would have learned Python / ArcPy, however ModelBuilder seemed an excellent tool and its only after lots of use that some of its limitations become apparent. The PC i am using has 16Gb RAM, so that is not the issue.
    – user21053
    Commented Sep 3, 2015 at 14:04

An option would be to export your models to python scripts and run them from the command line, completely avoiding the need for ArcCatalog/ArcMap to be open.

  • 1
    It is always worth a try but if the models use any iterators, or much beyond a string of tools, then there is a good chance that you will need to debug the code that results from an export, and that code has poor readability due to the way it names variables. The idea of running from the command line or an IDE like IDLE to avoid the overhead of ArcCatalog is a good one.
    – PolyGeo
    Commented Sep 2, 2015 at 2:45
  • @PolyGeo makes a good point. Models which use any type of recursion will require that code to be written after export, but that's not too difficult if you have an understanding of those concepts
    – Adam
    Commented Sep 2, 2015 at 2:49
  • yes the models I use have lots of iterators, lots of mixing back and forth between vector and raster data and have many layers of nested submodels, so exporting all these to make it run outside of ModelBuilder is not an option, due to the time it would take to convert it all.
    – user21053
    Commented Sep 3, 2015 at 14:07
  • are you running these in ArcMap or ArcCatalog? if in ArcMap, try simply saving the MXD between each run of the model and see if that helps at all.
    – Adam
    Commented Sep 3, 2015 at 23:02
  • the models are run from ArcCatalog.
    – user21053
    Commented Sep 8, 2015 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.