I am following the steps recommended by ESRI:

  1. extrude polyline in ArcScene
  2. Save as Layer File
  3. convert Layer file to multipatch
  4. convert multipatch to Collada
  5. import collada file to Sketchup
  6. edit model in SketchUp
  7. start editing in ArcScene
  8. select multipatch with Edit Placement Tool
  9. Replace with Model - Navigate to saved skp (NOTHING HAPPENS)

This only seems to (sort of) work if I export from SketchUp to Collada but only fully closed faces (and only some faces) are visible in ArcScene. Some faces can be seen from the reverse side. It's basically a mess. Not what I was expecting.

Why can't I replace the SketchUp model itself? Is this procedure only meant for very simple models?

I initially wanted to build the model in SketchUp but it seems impossible to export anything out of ArcGIS without the SketchUp 6 Plugin for ArcGIS. Exporting complex surfaces to COLLADA almost always fails and since TIN cannot be exported to SketchUp directly, it has to first be converted to Multipatch. This either fails if the surface is not very simple or yields unusable results. I then decided to do it the other way around (build the model in ArcScene and add SketchUp models to it) but I don't seem to be able to replace simple multipatches with models edited in Sketchup.

I was able to create large Sketchup models in the past (up to version 9.3.1) with complex TIN, polygons, points and lines exported directly from ArcGIS using the SketchUp 6 plugin. I am not really sure what the workflow should now be if the recommended ESRI workflow doesn't really work.

  • Are the SketchUp models true solids? "In SketchUp, a solid is any 3d model (component or group) that has a finite closed volume. A SketchUp solid cannot have any leaks (missing faces or faces that do not meet at an edge)."
    – blah238
    Oct 25, 2011 at 20:54
  • Regarding this comment I don't think that is the issue, see my other comment. I used one of the simplest possible solids (a cube) to try replacing another fairly simple solid (a cylinder) and nothing happened.
    – blah238
    Oct 25, 2011 at 23:07
  • Have you tried avoiding the usage of "space/s" on the .dae and multipatch .shp filenames. It might work. Jun 6, 2017 at 20:11

1 Answer 1


I found this statement:

The use of relatively simplistic 3D models is recommended for display and analysis in ArcGIS. Note that 3D models with very large volumes of textures or highly complex geometries may not import or display in ArcGIS.

I thought my model was fairly simple. How do people create large 3D models with Sketchup and ArcGIS? Is it even possible?

  • Well I tried your steps and found the same issues. I don't think you are doing anything wrong, more likely the command is simply not working as advertised. If you have FME or the Data Interop Extension give those a shot. I have had some success converting KMZ/Collada to Multipatch in the past.
    – blah238
    Oct 25, 2011 at 23:05
  • I don't have the Data Interop extension although if i knew for certainty that it would work i would probably get. However I am increasingly less certain ESRI software as the version number increases.... Not sure what FME is. Can you provide a link? Oct 26, 2011 at 13:07
  • 1
    FME (Feature Manipulation Engine) is the full-blown standalone and server side version of the Data Interoperability Extension, or rather, Data Interop is a subset of FME integrated into ArcGIS. It's a spatial ETL package that supports hundreds of data formats and transformations and has a "ModelBuilder on steroids" interface for designing data transformation workflows (FME Workspaces) that you can then run locally or on FME Server.
    – blah238
    Oct 26, 2011 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.