3

I'm using QGIS with a Panasonic Toughpad FZ-M1 with inbuilt dedicated GPS. I can connect okay to the GPS using View --> Panels --> GPS information. Satellites and signal strength show up, but no GPS information shows up (i.e. no positional data or any other attributes) in the GPS information window, and no cursor shows on the map. The GPS reports positional data okay when connected to GPS Viewer tool, so the problem appears to be specific to QGIS and the Panasonic Toughpad. I have tried the solutions listed here (Using the Live tracking with internal GPS?) but they do not work for me. Does anyone have any other suggestions to fix this problem?

  • Does the GPS work if the battery is taken out of the Toughpad? – Omer Sep 8 '18 at 7:36
3

I managed to solve this. Turns out QGIS does not handle NMEA data with the prefix $GN, only with the prefix $GP. The GPS chip on the Panasonic Toughpads is a u-blox M8, so I installed u-blox “U-Centre” software, opened and connected to the COM4 port. Then:

  • View → Configuration view → NMEA (NMEA Protocol)
  • Change “Main Talker ID” to “1 – GP(GPS)”
  • Click SEND, then POLL to check changes were sent to receiver

Now it works perfectly with QGIS live tracking :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.