4

I have a shapefile (calling it 'new.shp' for discussion's sake) that won't show up with other layers.

If a fresh file is started and I bring in new.shp, it will appear, but any other layers imported after does not. On the flip side, if other layers are imported first, the other layers appear, but new.shp will not show up.

That's not too much detail to troubleshoot from, but I was hoping someone might be able to suggest what the issue might be?

I've just started learning GIS and using QGIS, so I'm a bit lost at the moment.

Other notes: - I looked into the CRS for new.shp which says (EPSG:4326, WGS 84); The other layers are also set to this. - Using QGIS 2.10.1 on Windows 7

  • 1
    What result do you get for that layer using Vector | Geometry Tools | Check Geometry Validity? – Simbamangu Sep 8 '15 at 6:20
  • 1
    Do you have .shx .prj and .dbf along the .shp as well? What extent does QGIS report with rightclick on the layer -> Properties, Metadata tab? – AndreJ Sep 8 '15 at 6:24
  • When you open new.shp first, what coordinates do you see in the status bar? Are they plausible lat/lon values, that is lat values in the range -90 to 90, for the area you are working in? – Redoute Sep 8 '15 at 6:56
  • Really appreciate the responses-- (The 'check geometry validity' process is stalled at 52%. It's a large file, so it could take some time.) – joat1 Sep 8 '15 at 8:53
  • The .shx, .prj and .dbf are with the .shp. In terms of the extent of metadata, it's reported: In layer spatial reference system units: xMin, yMin 10580040.99, -1231313.95 : xMax, yMax 15699360.899,677736.15 Layer spatial reference System: +proj=longlat +datum=WGS84 +no_defs --Looking at the metadata and status bar, it seems the lat/lon are not plausible. Is there a way to adjust the lat/lon? – joat1 Sep 8 '15 at 8:54
6

If there is a .prj file, look into that with a text editor for projection information. Otherwise you have to ask the data creator.

It is definitely something projected in meters or foot. That is the reason you will not see it in a 180/90-degree view of the world, as defined by the WGS84 EPSG:4326 CRS.

To sanitize the project, remove the layer. Under Settings -> Options, CRS tab, CRS for new layers, select Prompt for CRS, and add the layer again. That should wipe away most CRS mistakes.

  • According to the .prj file, the projection is in fact in meters. Would it be possible to change this? – joat1 Sep 8 '15 at 9:29
  • It is safer to remove and re-add the layer, as you can see in my extended answer. If there is a .qpj file created, remove that before. If QGIS still asks for a CRS, remember the text after PROJCS in the .prj file and search for it in the CRS list. – AndreJ Sep 8 '15 at 9:58
  • 1
    ... and please promise to NEVER use Set CRS for Layer again unless you are told to do so. – AndreJ Sep 8 '15 at 10:31
  • 1
    please promise to NEVER use Set CRS for Layer again unless you are told to do so - Maybe this should be included as a start-up tip :) – Joseph Sep 8 '15 at 11:04
  • After changing the settings and looking at the text after PROJCS in the .prj file to search from the CRS, all is working now! – joat1 Sep 9 '15 at 7:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.