3

I have point features with text labels on my map. When I export as PDF, I can search elements that were constructed in the print composer, like the legend, scale bar, etc. However, labels of features on the map are not exporting as searchable text.

I've tried exporting in SVG and PDF. I'm not exporting as raster. Just to be sure I've isolated the problem I've also tried to export a map with just my text labels and get the same issue (text labels not searchable).

5

Yes, although it comes with some side effects. You need to change the label rendering from "outlines" to text objects. This setting slightly degrades the quality of rendered labels, and will also result in alignment issues with buffered text. To change this setting, you need to:

  • open the layer properties, switch to the labels tab
  • click the button in the top-right corner which looks like a blue arrow (tooltip says "Automated placement settings")
  • uncheck "Draw text as outlines"

This setting will apply to all layers in your map.

  • Thank you very much for getting back to me. I tried your suggestion, but unfortunately , it did not work for me. I'm not sure how to post a reproducible example here. Are there other things I should be aware of? (specific fonts to avoid?) – t.kalinowski Sep 12 '15 at 12:32
  • Are you on osx? – ndawson Sep 12 '15 at 12:58
  • Yes. 10.10.5. I've tried with both qGIS 2.8 and 2.10 – t.kalinowski Sep 12 '15 at 13:00
  • I don't think this is possible on OSX. Something about the built in OSX PDF printer automatically converts all text to outlines. If you have access to a windows or Linux build it should work – ndawson Sep 12 '15 at 13:01
  • OK, thank you. I have access to a windows machine. I will try it and report back. – t.kalinowski Sep 12 '15 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.