Does anyone know how to build GDAL with libcurl support on Debian Linux (specifically LinuxMint and/or Ubuntu)?

After following build instructions here and tip from @EvilGenius below, I'm specifying the path to libcurl with this command:

./configure --with-curl=-L/usr/lib/x86_64-linux-gnu

and I've also tried:

./configure --with-curl=/etc/ssl/certs/ca-certificates.crt

EDIT: I've built on a machine with PostGIS installed, for what it's worth, but I'm still not getting CartoDB as a data format in the list of supported formats.

Is there a way to check if GDAL was indeed built with libcurl support?

  • The Debian GDAL packages appear to have cURL support built in by default (search for 'cURL Support') and I believe it's built by default as long as you have the proper libraries installed. Are you using a package/compile that you are having issues with? – Evil Genius Sep 9 '15 at 17:36
  • @EvilGenius updated my question with some errors I'm getting... thanks again! – DPSSpatial Sep 9 '15 at 20:10
  • Anything prefixed with PQ is generally related to PostgreSQL. Make sure you have all your libs (-dev packages) installed or disable that support. – Evil Genius Sep 9 '15 at 21:19
  • Ah right I think this is the problem that I am trying to install this from a client machine, rather than one with PostgreSQL installed... – DPSSpatial Sep 9 '15 at 21:41

Both of those commands are wrong. It should be something like,

./configure --with-curl=/usr/bin/curl-config

curl-config is an executable which provides details on the curl version and locations of libraries, etc.

You can get this information by typing,

./configure --help|grep curl

But as EvilGenius says, you shouldn't need this command at all. Make sure curl is actually installed, of course.

MB Edit:

The correct libcurl installation syntax is:

apt-get install libcurl4-gnutls-dev

(once I had that installed, the config option above worked great and the installation allowed the CartoDB format to show up)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.