I am following this tutorial to build QGIS from source. The CMAKE dump is as below.

-- QGIS version: 2.8.3 Wien (20803)
-- Found GRASS: c:/OSGeo4W/apps/grass/grass-6.4.4 (6.4.4)
-- Found Proj: C:/OSGeo4W/lib/proj_i.lib
-- Found GEOS: C:/OSGeo4W/lib/geos_c.lib (3.4.2)
-- Found GDAL: C:/OSGeo4W/lib/gdal_i.lib (1.11.2)
-- Found Expat: C:/OSGeo4W/lib/libexpat.lib
-- Found Spatialindex: C:/OSGeo4W/lib/spatialindex_i.lib
-- Found Qwt: C:/OSGeo4W/lib/qwt.lib (5.2.1)
-- Found Sqlite3: C:/OSGeo4W/lib/sqlite3_i.lib
-- Found PostgreSQL: C:/OSGeo4W/lib/libpq.lib
-- Found SpatiaLite: C:/OSGeo4W/lib/spatialite_i.lib
-- Found Qt version: 4.8.6
-- Touch support disabled
-- Found QScintilla2: C:/OSGeo4W/lib/qscintilla2.lib (2.8.4)
-- Pedantic compiler settings enabled
-- Found Python executable: C:/OSGeo4W/bin/python.exe
-- Found Python version: 2.7.4
-- Found Python library: C:/OSGeo4W/apps/Python27/libs/python27.lib
-- Found SIP version: 4.16.5
-- Found PyQt4 version: 4.11.3
-- Found QScintilla2 PyQt4 module: 2.8.4
-- Found QwtPolar: C:/OSGeo4W/lib/qwt.lib
-- Found GSL: C:/OSGeo4W/lib/gsl.lib;C:/OSGeo4W/lib/cblas.lib
-- txt2tags not found - disabled
CMake Warning (dev) at cmake/SIPMacros.cmake:131 (GET_TARGET_PROPERTY):
  Policy CMP0026 is not set: Disallow use of the LOCATION target property.
  Run "cmake --help-policy CMP0026" for policy details.  Use the cmake_policy
  command to set the policy and suppress this warning.

  The LOCATION property should not be read from target
  "python_module_qgis__core".  Use the target name directly with
  add_custom_command, or use the generator expression $<TARGET_FILE>, as

Call Stack (most recent call first):
  python/CMakeLists.txt:141 (ADD_SIP_PYTHON_MODULE)
This warning is for project developers.  Use -Wno-dev to suppress it.

Browse other questions tagged or ask your own question.