1

I have TileCache + Mapnik working with a custom osm.xml stylesheet. When I run tilecache_http_server.py the tiles are served OK. But when I run TileCache under Apache (with mod_wsgi) I see incomplete tiles (with missing layers). What can go wrong? Furthermore, generating tiles is very slow. Can this have something to do with the missing layers? Thanks.

  • This doesn't sounds like a programming question. You should ask questions like this on GIS.stackexchange.com instead. – Jonas Oct 27 '11 at 20:54
  • Probably you are right. But it might be something in constructing the stylesheet... or something. – Peter Hulsen Oct 27 '11 at 21:59
  • different users with different permissions perhaps? – Ragi Yaser Burhum Oct 27 '11 at 23:10
  • If generating tiles is very slow, then some tiles don't appear, the problem appears to be an issue of one or more requests timing out. What if you increase the apache timeout default? Are you getting any errors in the Apache logs? – nmtoken Sep 21 '16 at 8:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.