Following this example (see the section "Use the Tiles as a CartoDB Base Map"), I am trying to add a set of xyz tiles to CartoDB, without success.

I exported a EPSG:3857 png from ArcGIS, and created tiles with gdal2tiles:

gdal2tiles.py combine_rc1.png fortiles -z 3-11

I uploaded these to an Amazon s3 bucket, and made them public. Here is one tile as an example: https://s3-us-west-1.amazonaws.com/amazonbasin/fortiles/3/2/3.png

Following the CartoDB example linked above, I then tried to add a custom xyz basemap:

Insert your XYZ URL:
Enter a url: https://s3-us-west-1.amazonaws.com/amazonbasin/fortiles/{z}/{x}/{y}.png

But this doesn't validate, and nothing is added to the map. The page says:

We couldn't validate this, if you're sure it contains data click "add basemap".

The example is for Google cloud storage. Should I expect this to work with Amazon s3? If so, what am I doing wrong?

  • I think the test CartoDB does is looking to see if tiles are at 0/0/0, which AWS says doesn't exist. The tiles do display, btw, if you zoom to the region you're interested in. It looks like there are some problems with the output, though because what should be continuous regions are stacked strangely. Double check the config you set in gdal2tiles. Maybe it's related to the profile needing to be 'mercator'? Sep 14, 2015 at 1:33
  • thanks @AndyEschbacher. I tried again, with the TMS parameter checked. I tried this earlier, to no effect, but now it works. So there must have been some caching going on that was preventing me seeing the tiles with the Y parameter reversed
    – toms
    Sep 14, 2015 at 2:18

1 Answer 1


From the comment by @AndyEschbacher, the validation just checks for a tile at 0/0/0. In my case I don't have a tile at 0/0/0, so validation (lack of validation) wasn't telling me anything.

Furthermore, I needed to check the option to add the tiles with the TMS parameter checked, which inverts Y axis numbering for tiles.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.