3

I am using ArcGIS 10.3 for Desktop.

When I export a data driven MXD using a strip index (i.e. 3 pages into a single pdf) it works fine the first time I export it.

However, if I try and export the same MXD again it crashes and I have to close and re-open the MXD.

This only occurs when data driven pages are used.

Does anyone have a solution to this, or is this a bug within the software?

  • 1
    Can you post your code? Are you writing to the same PDF name? – code base 5000 Sep 14 '15 at 10:49
  • What precisely do you mean by "it crashes"? Does it throw a Serious Application Error or do something else? – PolyGeo Sep 14 '15 at 10:50
  • I haven't used any code, simply using data driven pages with a strip index. When I say it crashes, the 'grey export box' that appears saying the map is exporting is showed, however no pdf is created. You can't close down the 'grey export box' (clicking doesn't close it down) and it is continuously displayed. I tried leaving it to export overnight and nothing had changed the next morning. The only difference I can see in the 'grey export box' is that it doesn't include the text 'Page 1 of 3' that it shows when exporting correctly. I hope this provides more clarification. – Tom Barker Sep 14 '15 at 11:37
  • Can you export other data using DDP without getting the crash? – code base 5000 Sep 14 '15 at 11:38
  • Nope. The only time it doesn't crash is the first time the DDP is exported after the MXD is opened. If I try and export anything using DDP after that it crashes. – Tom Barker Sep 14 '15 at 11:47
0

I have had this same issue with the same steps you described. I disabled these two items and have exported a few pdfs since, but haven't really check to see if the issue is fixed.

Will you try unchecking these options under System Properties > Advanced > Performance Options:

  • Animate controls and elements inside Windows
  • Enable Desktop Composition
  • This solution doesn't work for our machines that are experiencing the export crash. – CStarbird May 6 '16 at 17:43
1

We've also had this problem since upgrading to 10.3. So for the only work around I've found is if you disable DDP then re-enable before re-exporting it prevents the crash. A bit of a pain but if you're like us, the time to disable and re-enable DDP is a lot quicker than having to reload the MXD.

0

Maybe you are low on memory, happens to me on my old laptop too. What helps to me was to close other memory "hungry" programs or to reduce the dpi of the export.

  • Not sure if that would be it, wasn't a problem in v10.2 - it's only started happening since I upgraded to 10.3 – Tom Barker Sep 15 '15 at 8:01
  • It is just an idea, but you can give it a try. Test it with your normal dpi, then test it again with 75 dpi. – André Sep 15 '15 at 8:18
  • I've tested using 75 dpi however it is still crashing unfortunately. I've also tried closing down every other program and it is still happening... good idea though Andre. My PC has 16gb RAM - it's pretty quick to perform other ArcGIS functions. – Tom Barker Sep 15 '15 at 10:55
  • Sorry to hear. Good luck with solving the problem. – André Sep 15 '15 at 11:13
0

I was having the same problem with 10.3. I found that refreshing the Data Driven Pages before I exported did the trick on keeping it from crashing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.