So I am using the trace tool to complete polygons. The problem I am running into is that the trace tool will run along my grid lines. This is easily avoided if the polygon is easily distinguishable from the grid line but if my polygon crosses a grid line at say 1-5 meters and I am collecting/creating polygons at 1:5,000 then theres no way for me to know that I just created the polygon along the grid line instead of the polygon. Does anyone know of a way to prevent the trace tool from tracing on my grid layer/layers. I have converted the grids to line work (to use production difference polygon) and then thought maybe converting to graphics would solve the problem but it did not. I also made the grids layer unselectable. Any suggestions?

The lime green line is the grid and the dark yellow is the polygon.

This is one that I probably would catch but...

enter image description here

enter image description here

  • why not just turn the grids completely off? – ed.hank Sep 14 '15 at 21:35
  • I would but I use them as a guide to not run into parts of the map I shouldn't be in. – Sjolster31 Sep 14 '15 at 21:49
  • 1
    I'd convert line work to raster – FelixIP Sep 15 '15 at 5:53
  • Does anyone know how to make the output raster "thinner". Its comes out looking too much like a polygon. I know its going to but I'm wondering if I can shrink the thickness of the output. – Sjolster31 Sep 16 '15 at 13:35
  • Before converting to raster set smaller cell size in Environment Settings-Raster Analysis – FelixIP Sep 16 '15 at 20:46

I think what you want - assuming you're using ArcMap - is the 'classic snapping' tool, which would give you the ability to set which layers you're snapping to, so you can turn off snapping to the grid you're running into.

enter image description here

  • Yeah I have snapping turned off for the grid but the trace tool still runs along the grids. – Sjolster31 Sep 14 '15 at 22:05
  • You've used the 'classic' snapping? I think that will allow you to dig down further... – DPSSpatial_BoycottingGISSE Sep 14 '15 at 22:25

Assuming that you are referring to the Trace tool in ArcMap, I think you should experiment with having the features in some layers selected, then, from the Help:

By default, the trace can follow along any feature near your pointer. If you want to trace only features that are selected, hold down the Ctrl key while tracing. There is also an option for tracing selected features on the Trace Options dialog box. (If you turn on the option, Ctrl then does the reverse, and temporarily allows you to trace any feature.)

  • This works but I need the ability to trace all my other layers/ features besides the grids layer/feature. – Sjolster31 Sep 14 '15 at 22:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.