Want to do some testing with Sharepoint/MapIt.

  • Took an existing machine with ArcGIS Server 10 on Windows Server 2008 on.
  • Installed Sharepoint 3.0 SP2 on it with basic install/default options.
  • Can now hit Sharepoint with http:///default.aspx
  • Can no longer hit manager or REST = 404
  • Under wwwroot, the ArcGIS folder is still there

So whats happened and how can I get the two to work side by side?

2 Answers 2


You can do this, but you'll need to configure distinct host headers on the IIS sites used by ArcGIS Server (probably Default) and SharePoint (probably SharePoint - 80). The underlying issue is that SharePoint and ArcGIS Server use different directories on disk.



To add components to particular web applications or site collections, use the -url parameter (e.g. "spconfigutility -install -url http://localhost:1234"). Multiple urls may be specified in one command (e.g. "spconfigutility -install -url http://localhost:1234 -url http://localhost:5678"). If the url is that of a web application (or site collection at a web application's root), then the ESRI Parts will be activated on each site collection within the web application. If the url only specifies a site collection, then the ESRI Parts will be activated only within that site collection

Since ArcGIS Mapping for SharePoint is built on the Microsoft Silverlight platform, IIS must also be configured so that it includes the following MIME types:

.xaml application/xaml+xml

.xap application/x-silverlight-app

.xbap application/x-ms-xbap

  • Thanks mapperz. Just for info, IIS7 = has these Mime types already ready to go. Ill leave Q open for few more days to see if i get some more As. I was hoping I could change something after ive already done the damage. I do have the option of rolling back if need be. Id also have preferred to have an option within the install options for ShPt as opposed to relying on a separate utility. But thanks again - if this is the only workaround, ill take it.
    – jakc
    Sep 1, 2010 at 23:11
  • Your welcome, glad it helps. If there is a better solution would like to know about it too.
    – Mapperz
    Sep 2, 2010 at 0:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.