2

I'm trying to use the feature search in ArcGIS Online, but until now without any luck. I have followed this instructions: https://doc.arcgis.com/en/arcgis-online/create-maps/configure-feature-search.htm, but when I reach the bullet number 6, I can, not find this option (Expand the Find Locations setting if it is not already expanded and check the By Layer check box.)

I have made standard map with ArcGIS Online, Add data to the map (from the internet), from my ArcGIS Server (MapService), Query data was enabled when data was published to the server, I can see data in my ArcGIS Online map. But I can not find the Option in ArcGIS Online to activate the feature search ?

Any ideas ?

The Instructions that I followed:

  1. Verify that you are signed in and open the saved map you want to configure for feature search.

  2. On the side pane, click the About this Map button to display the map's details.

  3. Click More Details to go to the map's item details page. Alternatively, you can open the map details from My Content.

  4. Click Edit on the item details page.

5.Scroll down to the Properties section and locate the Application Settings.

6.Expand the Find Locations setting if it is not already expanded and check the By Layer check box.

7.Choose a layer from the drop-down list.

Note: Hosted feature layers and ArcGIS for Server feature and map service layers with Query enabled are searchable (and therefore appear in the drop-down list). For example, if you are publishing your feature data from ArcMap, you can enable the Query operation through the Service Editor. See ArcGIS for Server Help for more details.

8.Choose an attribute field in the layer. Note: For a field to be searchable (and therefore appear in the drop-down list), it must contain strings or integers and not use a coded domain. Integer fields only support the Equals condition. For the best search results, choose a field with unique values.

9.Choose whether the result should contain or be equal to the search terms.

10.Enter hint text that will appear in the search box when the user selects to search in a layer. The same hint appears for all your searchable layers.

11.Repeat the process to enable search on additional layers.

12.Click Save.

  • My only 'workaround' to the same problem - which I don't want to use in production - is to make the service a feature service - then all works as expected. – user64583 Jan 2 '16 at 22:38
  • Did you turn the Shape field off? I turned mine back on and it seems to work now. – user80970 Aug 17 '16 at 18:35
1

You should go to Your Content page. There you should see an option to your web map and another to your web map APP. You will find the search options on the first one, not the latter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.