6

I have a new laptop with a very high resolution screen and can't get QGIS to work properly.

Icons and text are too small.

I tried to change the resolution, but had no luck.

I also tried to change settings in QGIS but that changes only text and some of the icons.

3
6
  1. Find the qgis executable. If installed with OSGeo installer, it is in C:\OSGeo4W64\bin.

  2. Right click on qgis-bin.exe and choose Properties.

  3. Select the 'Compatibility' tab (the second tab).

  4. Select 'Change high DPI settings' at the bottom of the tab.

  5. Check 'Override high DPI scaling behavior' at the bottom.

  6. Select 'System (Enhanced)' from the drop down.

Now, Start the application.

https://danantonielli.com/app-scaling-on-high-dpi-displays-fix-2019/

1
  • your solution works on my screen and even on the remote desktop connection. – Zac Apr 6 '20 at 0:41
1

Finally I just reduced the screen resolution to 1920 x 1080, works OK

1
  • If you want to keep the high resolution you might go into your display settings and change the size of text and other items. Different Windows versions and different programs in Windows handle scaling differently, however, so you have to test it out yourself. – johns Sep 18 '15 at 12:51
1

While adjusting screen resolution and/or text size can solve the problem, I'd like to point out that there are inconsistencies between QGIS tools. Some tools will display at high res, while others are only readable at lower res. Here are two examples taken from a Microsoft Surface Book, 3000 X 2000 resolution screen, text size 200% (recommended), QGIS 2.14.2. At this setting the Spatial Query tool displayed correctly:

enter image description here

However, at the same display settings, the Select by Location tool is unreadable and unusable (although it will display correctly at 1920 X 1080, text size 100%):

enter image description here

Perhaps the fine people that create these tools could modify their code to work correctly with the higher resolution screens that are becoming more common!

1

Through additional research I've uncovered a method that elegantly and completely solves this high-dpi QGIS problem (at least for Windows 10 machines) without having to reduce the screen resolution. I've successfully used it on a 3000 x 2000 dpi Microsoft Surface Book, as well as a 3840 x 2160 screen, both at full resolution.

The solution is at: http://www.danantonielli.com/adobe-app-scaling-on-high-dpi-displays-fix/

While the solution's author was working with Adobe products, it works with other applications, including QGIS.

Finally, the solution website has a donation button. Consider helping out if the solution works for you.

3
  • Stu Smith - I tried to use this, having a problem. For QGIS, the Program Files\QGIS Brighton folder does not have any sort of .exe Probably some sort of open source difference. Here's my screenshot to show you: flic.kr/p/HiivFN – nittyjee Mar 24 '18 at 0:01
  • @nittyjee The manifest file needs to be copied to the same folder containing the file qgis-bin.exe. For QGIS 2.18.16, that folder is c:\osgeo4w64\bin\. After you've copied the manifest file to that folder, rename the file to qgis-bin.exe.manifest, then restart QGIS. Voila! – Stu Smith Mar 25 '18 at 16:20
  • Thank you so much, that worked. One thing to note - for me, when I chose decimal and reopen it, it shows that it's back to hexadecimal. This doesn't matter at all. From elsewhere online I found someone posted this: "The option to switch between the two is purely to allow entry in either format, it is always stored in Hex and for convenience the Decimal value is shown in brackets afterward in the field view. Selecting either option would have absolutely no effect on the program accessing the value and is the same either way." – nittyjee Apr 10 '18 at 19:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.