1

I am creating Network Analyst tools for people who are very light users and need things to basically be buttons. Because of the way we use GIS this can't be done in a web application or any light form of GIS. Each user has ArcGIS Desktop installed and the toolbar I am trying to create needs to be very user friendly. (point and click)

This toolbar essentially needs to be Network Analyst light with singular functionality. I have all the tools created but I am having trouble creating a button that adds the Route as the Network Layer. The problem is the model needs to be validated or I need to press "run entire model" for the route layer to be added. I have also tried a python script and I can get it to work if I copy and paste the code through the python geoprocessing window. If I add the script as a command and make a button it says it works but the route layer isn't added. Also, if I just open the model I run into the same problem with the layer not being added. In order for it to work I have to edit the model and use the model builder window to run the model.

My questions basically comes down to is there any way to create a command button that runs the entire model or validates the model before it is run? or a script that can validate a model? or has anyone else dealt with this and found a workaround?

The model is very basic... just the "Make Route Layer"tool.

closed as unclear what you're asking by PolyGeo Aug 29 '16 at 0:29

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • So you've saved a model with the input parameters already specified? I'm not sure that you can trigger validation without either changing the parameters or manually doing it as you have. – Evil Genius Sep 18 '15 at 15:17
  • Yeah,the parameters are preset since it will always use the same input analysis network . – nebula026 Sep 18 '15 at 15:20
  • So it is very weird but if I make the "Output Layer Name" a parameter under the Make Route Layer Tool it works..... even though there isn't actually a parameter to fill in since in the tool I told it to call it "Route." – nebula026 Sep 18 '15 at 16:19
  • My understanding is that tool validation is always run as a tool opens so what you are asking is unclear to me. – PolyGeo Aug 29 '16 at 0:28