I've got a feature layer of certain fields (which I converted to raster), and a raster layer of different vegetation types. I now want to compute the area of each vegetation type for each field. For this I used the tabulate areas tool which did not give me any errors, but I lost some ID's. Now I read that this seems to be a general problem with big datasets.

Still I would like to ask if someone has a solution/ workaround for this that will give me the same result in the end. I'm new to python programming and have not been able to find a solution myself.

I furthermore have some entries in my resulting tables that simply do not make sense when looking at the original data. I'm worried now that the values for all entries are wrong and I cannot use them at all.

This is what my code looks like:

 inZoneData = "Field_Rast"
 zoneField = "Value" 
 inClassData = "vegtypes.tif"
 classField = "Value"
 outTable = "C:/data/areatable.dbf"
 processingCellSize = arcpy.env.cellSize = "vegtypes.tif" 

 TabulateArea(inZoneData, zoneField, inClassData, classField, outTable, processingCellSize)

This is a small part of the table I get where you can see that the object ID and the value do not match and in fact I have fewer OIDs than I did original values.

Example of table with missing IDs

Edit: The datasets are originally not in the same coordinate system, but I transformed them before taking this step

  • You could also try to convert your vegetation types raster into vector polygons (resources.arcgis.com/en/help/main/10.1/index.html#//…) and then union the two vector inputs (resources.arcgis.com/en/help/main/10.1/index.html#//…). You could then perform summary statistics (resources.arcgis.com/en/help/main/10.1/index.html#//…) on the union result to sum the areas by vegetation type. Sep 22, 2015 at 15:07
  • The disparity in your values could be down to your rasters having different coordinate systems and cell sizes? Please edit your question to include this information.
    – Hornbydd
    Sep 22, 2015 at 21:24
  • I tried out your proposal @BrentEdwards, assuming you meant the Union tool in the Analysis toolbox (link points to raster to polygon conversion). Seemed to have worked at first, but the resulting feature class cannot be opened in ArcGIS, nor can it be used for further processing. Kind of confused right now.
    – sdots
    Sep 24, 2015 at 12:42
  • Just saw that it is actually missing the shapefile - anybody know why?
    – sdots
    Sep 24, 2015 at 13:05
  • Yeah, sorry for the bad link. It is in fact the Union tool in the Analysis toolbox - resources.arcgis.com/en/help/main/10.1/index.html#//…. What format are your Union inputs and output (ex. shapefile, file gdb feature classes)? What message is ArcMap displaying when you try to open the output? Do your inputs overlap? Sep 24, 2015 at 17:35


Browse other questions tagged or ask your own question.