1

I'm using the v.kernel function in GRASS to create heat maps. I am able to generate an acceptable heat map using a std deviation of .2 and a several thousand rows and columns. After the map is generated, I look at it in QGIS.

v.kernel input=data output=heatmap stddeviation=.2

However, if I go to a std deviation below .2, all I get is a black rectangle. A std dev of .19 or .1 or .01 results in no variation being shown on the heat map, just all black. Does anyone know why this might be? I want to be able to increase the granularity and precision of the maps I'm creating, and lowering the stddeviation would seem to be the solution.

  • what is your map unit and the distance between closest points ? – radouxju Sep 22 '15 at 19:41
  • At the module manual, grass.osgeo.org/grass64/manuals/v.kernel.html, there is a -q flag whose function is only calculate optimal standard deviation and exit (no map is written). – xunilk Sep 22 '15 at 19:44
  • @radouxju the map unit is in degrees. As far as the closest points, I am not sure, but there are hundreds of thousands of points and there are bound to points practically on top of one another as these are IP addresses for every AS in the United States that I am mapping. – tobydog Sep 22 '15 at 19:53
  • @xunilk I tried that option but due to the enormous amount of data, I ran into an error where GRASS cannot allocate enough memory in order to calculate this optimum std dev. – tobydog Sep 22 '15 at 19:54
  • have you tried epanechnikov instead of gaussian (the default), so that you don't look too far ? – radouxju Sep 22 '15 at 20:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.