1

I have got two existing rasters that have the same cell size (5x5m). The corner of cells from raster A are located exactly at the centres of cells in raster B. I want to place raster B exactly on top of my raster A.

I have tried these options:

  1. the tool 'resample' on raster B, while maintaining the same cell size and snapping to raster A.
  2. the tools 'raster to points' and consequently 'points to raster' on raster B, again, maintaining the grid size and snapping to raster A.
  3. the tool 'copy raster', snapping raster B-copy to raster A.

All options have the same result: raster B is still exactly where it lay before, with the corners of cells in B at the centre of cells in A.

Whenever Google this problem, I end up at 'environment settings' when making the grid for the first time - but I do not have the data on which the grid was based. Do you have any suggestions on how I could solve this, without a need for the original data?

I am working in ArcGIS 10.2.1. I've got a basic license, but might be able to do an upgrade to Standard or Advanced if necessary.

Edit: the raster files are .asc files.

  • 1
    what is the format of your raster files ? – radouxju Sep 30 '15 at 12:08
  • 1
    I would say ASC is not a true raster format, more of an interchange format, I would convert your ASC files into something like a tiff. – Hornbydd Sep 30 '15 at 12:12
  • Thanks for your suggestion. I tried this; at first it did not work because when dragging and dropping the .asc files to the input field in the ASCII to raster tool, the data type was invalid. However, I learned that sometimes, somehow if you select the .asc file via de browse icon, it does work. Anyway, after I succeeded I still had the same problem. In the end, the problem appeared to be a bug in ArcGIS (see below). – Renée Sep 30 '15 at 14:57
1

To align raster A so that it sits on top of raster B I would use the copy raster tool to copy A to a new raster called "A2" and make sure the environment setting snap raster is set to B. If you look at the help file for this or any other geo-processing tool it has a section called Environments, these are the settings that the specific tool honours.

Copy Raster honours Snap Raster and you can set that to be an existing raster, in your case raster B.

  • I've tried to use 'copy raster', but same as for the other tools, the 'snap raster' in the environment settings does not seem to work. I think it might have to do with the fact that cell corners of raster B are exactly at the centre of grid cells of raster A (and vice versa). – Renée Sep 30 '15 at 12:15
1

A similar question has been asked before. Apparently, there is a bug in ArcGIS 10 that can be circumvented by turning off background processing. For the full answer, see: https://gis.stackexchange.com/a/34172/12855

Not the answer you're looking for? Browse other questions tagged or ask your own question.