3

I'm trying to use the area of a paddock as its label. The layer is a shapefile containing a single polygon. In Layer Properties/Labels/Label this layer with I define an expression:

concat(tostring(round($area/10000,2)),'Ha')

The preview correctly yields 4.67Ha but canvas renders 0Ha.

The shapefile .prj file:

PROJCS["NAD83_NSRS2007_UTM_zone_59N",GEOGCS["GCS_NAD83(NSRS2007)",DATUM["D_NAD83_National_Spatial_Reference_System_2007",SPHEROID["GRS_1980",6378137,298.257222101]],PRIMEM["Greenwich",0],UNIT["Degree",0.017453292519943295]],PROJECTION["Transverse_Mercator"],PARAMETER["latitude_of_origin",0],PARAMETER["central_meridian",171],PARAMETER["scale_factor",0.9996],PARAMETER["false_easting",500000],PARAMETER["false_northing",0],UNIT["Meter",1]

The measure tool ellipsoid is Clarke 1866

QGIS 2.8.3/Windows.

6
  • 1
    Can you confirm that the area isn't simply too small? Sep 30, 2015 at 19:11
  • 1
    It works fine for me (2.8.2).
    – dmh126
    Sep 30, 2015 at 19:12
  • 1
    Also that you're using a projected coordinate system with units in metres. Sep 30, 2015 at 19:13
  • Is what area 'too small? 4.67 hectares is surely a large enough area to be mappable. The project-level CRS is EPSG:3706, NAD83(NSRS2007) / UTM zone 59N and canvas units ( CRS transformation:ON) is meters. Despite repeatedly setting layer-level projection to same, whenever I select Set Layer CRS I do get an anomalous message: This layer appears to have no projection specification. By default, this layer will now have its projection set to that of the project, but you may override this by selecting a different projection below.
    – Bad Loser
    Sep 30, 2015 at 20:57
  • Hmm, sounds like it could be an issue with on-the-fly projection. Does your shapefile include a .prj file? Oct 1, 2015 at 4:23

1 Answer 1

1

The seeds of this problem were user error combined with what I perceive as a bug in QGIS and were sown many steps previously from the moment I saved the imported GPX file as a line-geometry shapefile:
How NOT to load and save a GPX file
(a) Start a new project (Default: OTF, CRS transformation DISABLED)
(b) Vector/GPS/GPS Tools/Load GPX file/Feature type: Routes
(c) Status line shows Scale=1:6314 and EPSG:4236 (Expected)
NB: Step (d) is the fatal mistake!!!
(d) Right-click layer/properties/Set CRS to EPSG:3706
(e) Right-click layer/save as/BUG.shp [CRS=EPSG:3706]
(f) Remove GPX layer and zoom to shapefile layer.
(g) Status line shows Scale=11:1 and EPSG:3706 (The clue I missed)
(h) Measure tool gives bizarre values. (e.g. cm instead of km)

[Note that setting OTF and (project-level) CRS=EPSG:3706 after step(a) does not affect the final result.]

Here is the ogrinfo 'BUG.shp' output:

INFO: Open ofC:\Users\DAZ\QGIS_maps\Kaihu\epsg3706\BUG.shp' using driver ESRI Shapefile' successful. Layer name: BUG Geometry: Line String Feature Count: 2 Extent: (173.689542, -35.756475) - (173.705586, -35.742893) Layer SRS WKT: PROJCS["NAD83_NSRS2007_UTM_zone_59N", GEOGCS["GCS_NAD83(NSRS2007)", DATUM["NAD83_National_Spatial_Reference_System_2007", SPHEROID["GRS_1980",6378137,298.257222101]], PRIMEM["Greenwich",0], UNIT["Degree",0.017453292519943295]], PROJECTION["Transverse_Mercator"], PARAMETER["latitude_of_origin",0], PARAMETER["central_meridian",171], PARAMETER["scale_factor",0.9996], PARAMETER["false_easting",500000], PARAMETER["false_northing",0], UNIT["Meter",1]]
[The Extent and LINESTRING (not shown) units are in degrees!]
This leaves me at a loss when trying to explain this behaviour as expected!

1
  • This is one of the most common beginner mistakes in QGIS, but it's not a bug. You simply shouldn't have changed the CRS in the layer properties.
    – csk
    May 11, 2018 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.